Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) ungrib.exe: internat compiler error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Jun Hu

New member
hi, I compiled the WPS 4.0, geogrib and metgrib all succeed, but ungrib failed. However, I compiled WPS3.7, and it succeed. Have you ever met this error? the error is about libpgu.a.

make[1]: [read_namelist.o] Error 2 (ignored)
/bin/rm -f cio.o
/bin/rm -f libpgu.a
ar ru libpgu.a build_hdate.o geth_newdate.o geth_idts.o swap.o table.o parse_table.o gbytesys.o gribcode.o read_namelist.o cio.o
ar: creating libpgu.a
ar: read_namelist.o: No such file or directory
make[1]: [libpgu.a] Error 1 (ignored)
echo libpgu.a
Can you attach your full compile log, as well as the configure.wps file? When you say that you compiled V3.7 and it was successful, was that recently (at the same time as you tried to compile V4.0), or was this a compile from some time ago? It may be helpful to attach the same files (configure.wps and compile log) for V3.7, as well - just make sure to name the files accordingly to differentiate between the 2 versions. Thanks!
Thanks for sending those. The error for V4 is an internal compiler error. It may be that the version of PGI you are using is too old for the newer version of WPS. Take a look at this "known problems" page for WPSV3.9. Look at the last problem/solution on the page.

Although this problem and error is specific to a gfortran compiler, the error you are getting essentially seems to be complaining about the same thing. As this page says, I would advise to upgrade to a newer version of PGI, or you can try to modify the code as recommended and see if that helps.
Thanks for suggestion. I found another solution for this error. I copied another ungrib.exe to WPS4.0 folder, and it actually worked. I will try to upgrade PGI version to see whether it works.