Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) ungrib.exe+metgrid.exe from WPS 4.1 not producing PMSL field ?

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Dear WRF-users,

We recently upgraded from WPS3.6.1 to WPS4.1 but wish to stay with WRF3.7.1 for the moment. Everything worked out very smoothly except that the PMSL variable is absent in the met_em files, and real.exe produced the following fatal error message:
"not enough info for a p sfc computation"

As suggested in the WRF portal we put the sfcp_to_sfcp = .true. option and had WRF running this way.

However, I wonder if the production of surface pressure can be considered as degraded this way, and why ungrib+metgrid from WPS4.1 foes not output this variable, while from WPS3.6.1 they did - starting from the same grib files ? Is there a way to force them to output this variable ?

Thanks by advance,


S. Mailler
I ran a test case with WPSV3.6.1 and WPSV4.1, using the same namelist and input data, and I am able to get the variable PMSL for both versions. Can you attach a GRIB input file, along with your namelist.wps that you are using for this so that I can run a test with your exact set-up? Just to verify, you didn't make any modifications to the WPS code, correct?
Thanks for the answer,

I found what the problem was, I also upgraded the Vtable files with the new version, and the Vtable.GFS needs to be modified to work with pre-Jan 14, 2015 GFS outputs as mentioned in the Vtable.GFS comments:

< # As of WPS V4.1 (April 2019) the default PMSL is changed to MSLET. MSLET is an unsmoothed sea level pressure.
< # NCEP included MSLET in their GFS files beginning 12z on 10 May 2011 and in their GDAS files at 12z 14 January 2015.
< # The smoother PRMSL is in all GFS/GDAS pressure files.
< # For GFS files prior to those dates use PRMSL as shown in the following line:
< # 2 | 102 | 0 | | PMSL | Pa | Sea-level Pressure | 0 | 3 | 1 | 101 |

Once this is done, everything works smoothly.
Thanks very much for following-up with a solution. Since this issue seems like it might affect others working with older GFS datasets, I've opened a GitHub Issue for this.