Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) WPS Build Stops with Message "/usr/bin/ld: cannot find -lwrfio_int"

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

thiagofferrari

New member
Hello everyone

I am trying to install WRF / WPS 4.0 on an amd_x86_64 architecture virtualbox with two single core processors and CentOS 8 OS.

I followed all the steps in the manual provided at the link <http://www2.mmm.ucar.edu/wrf/OnLineTutorial/compilation_tutorial.php> without problems until the time of compiling WPS. Compilation always stops with the message "/ usr / bin / ld: cannot find -lwrfio_int".

I was able to compile WRF in dmpar / em_real mode and all the libraries required by WPS with no apparent problems.

could you help me?
 

Attachments

  • log.compile
    101.5 KB · Views: 53
  • configure.wps
    3.6 KB · Views: 46
Hi,

Please take a look at the post here to see whether it is helpful for you.

https://forum.mmm.ucar.edu/phpBB3/viewtopic.php?f=37&t=345&p=1002&hilit=virtualbox#p1002

We are not able to support the code building in virtualbox because it it hard for us to repeat the problems caused by various factors. However, if you have a solution to the problem, please post it to the forum. I suppose such information will be helpful for other users who may have the same issue.

Thanks.
 
Top