Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) WPS configure error: Error: No compiled WRF code found.

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I tried to compile WPS-4.2
given command ./configure;
got the message below:
Will use NETCDF in dir: /home/razib/Build_WRF/LIBRARIES/netcdf

Error: No compiled WRF code found. Please check that the WRF model has been compiled
one directory level up (i.e., ../) in a directory named 'WRF', 'WRF-4.0.3', 'WRF-4.0.2', etc.,
or specify the full path to the compiled WRF model with the environment variable $WRF_DIR .

I am very new to WRF.
I do not know which files to provide, please ask me in specific

I need some help regarding this issue.


  • Screenshot from 2020-05-04 15-29-53.png
    Screenshot from 2020-05-04 15-29-53.png
    39.4 KB · Views: 1,675
  • Screenshot from 2020-05-04 14-47-14.png
    Screenshot from 2020-05-04 14-47-14.png
    47.3 KB · Views: 1,676
Have you compiled WRF yet? If so, then you can set the path to the WRF compile with the "WRF_DIR" environment variable - something like:
setenv WRF_DIR path_to_your_wrf_compile/name_of_your_compiled_wrf_directory
I am a new user WRF and presently have successfully compiled WRF and the compiler used is gfortran.
After configuring WPS with gfortran compiler serially, the command as per the standard installation manual "WRF_DIR = ../WRF" is giving the error
**bash: WRF_DIR: command not found...**
Please let me know what might be the associated problem.
If you're using bash, the command should be
export WRF_DIR=../WRF

If you haven't tried that, please give that a try and see if that helps.