Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) WPS PGI: /usr/lib64/mpich-3.2/lib: file not recognized: Is a directory

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi wrf forum!

I am wondering if you could help me.
I am trying to setup WRFV4 and WPSV4 (I will then use these for GSI). I am using a PGI compiler.
In WRF, I run
./configure with options 52 then 1
./compile em_b_wave >& compile_wrf.log (attached, also added my configure.wrf)
This seems to work fine, configuration is successful.

Then onto WPS.
./configure with option 5, I get this output
Configuration successful. To build the WPS, type: compile

Testing for NetCDF, C and Fortran compiler

This installation NetCDF is 64-bit
C compiler is 64-bit
Fortran compiler is 64-bit

Your Fortran + NETCDF did not run successfully.

So I am kind of confused if this is successful. Configuration was successful but Fortran + NETCDF isn't.
So I then run:
./compile >& compile_wps.log (Attached, also added the configure.wps)

As you can see, it doesn't compile geogrid or metgrid. I have no idea why!

I tried changing configure.wps so that WRF_DIR = ../WRFV4, which got rid of the error message, but still didn't help configure (this is also attached as compile_wps_edit.log). My Environment is set up like so:

export CC=pgcc
export FC=pgfortran
export LD=pgfortran
export F90=pgfortran
export FFLAGS="-O2 -Msignextend"
export CXX=pgcpp
export CPPFLAGS="-DpgiFortran"
PGI version:
pgcc 17.5-0 64-bit target on x86-64 Linux -tp haswell
PGI Compilers and Tools
(I need to use this one for my GSI setup)

I hope I have supplied all the information needed in case anyone can help me! This has been driving me crazy for a few days now.

Thank you for your time!


  • compile_wps.log
    47 KB · Views: 49
  • compile_wps_edit.log
    104.1 KB · Views: 57
  • compile_wrf.log
    713.5 KB · Views: 45
  • configure.wps
    3.7 KB · Views: 51
  • configure.wrf
    20.1 KB · Views: 51

In your file 'compile_wps_edit.log' you have this error:
/usr/lib64/mpich-3.2/lib: file not recognized: Is a directory
make[1]: [geogrid.exe] Error 2 (ignored)

Since you are not compiling WPS in parallel mode, MPI should not be necessary or causing problems. This leads me to believe that there may be some sort of environment setting that is causing the WPS build to look for this. Can you issue the following:

env >& env.log

and then send that file?


You have an environment variable set that is pointing to this
MPI_LIB = /usr/lib64/mpich-3.2/lib

Can you try to unset that and see if you can get past that error? After you unset it, you'll need to issue a 'clean -a' and then reconfigure before you recompile. Let me know if that fixes the problem.