Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(Resolved) WRF configuration errors

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am following the tutorial (https: // to install WRF on an Azure VM. I have used this tutorial for several successful installations on other machines previously.

I made sure to set the proper paths to ensure the same compiler (GNU) is used throughout the process. The library compatibility tests work with no error. However, when I attempt to run "./configure" from the WRF directory, I am prompted for the options 1-75 and nesting options 1-3, but after entering "1" for basic nesting get the following error: "cannot append configure.wrf at arch/ line 780.
configure.wrf not created! Exiting configure script..."

When I run "sudo ./configure" I get the error: "checking for perl5... no
checking for perl... found /usr/bin/perl (perl)

No environment variable NETCDF set.

As a note, entering "echo $NETCDF" and "sudo echo $NETCDF" both result in the expected path (set by previous command "export NETCDF=$DIR/netcdf" when building NetCDF). I'm really not sure what is happening here- I'm guessing something is going on with sudo since my past experiences have worked fine when sudo permissions were not used.

Any suggestions on how I can get WRF to successfully configure and recognize netcdf properly would be greatly appreciated.

Thank you!

To solve this issue, I was able to get WRF to configure using "sudo -E ./configure" to preserve the environment variables set previously.

Hope this helps others!

I'm glad you were able to resolve it, and thank you for updating to let us know how!