Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) WRF V4.3 runs are considerably slower than WRFV4.2 with exactly the same namelist options

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I had been running simulations using WRF V4.2. Now, when I try to do those same simulations again using a new installation of WRF 4.3 version, it is slower by almost six times. Is WRF 4.3 supposed to be this slow or might something have gone wrong with the compilation of the new version (It was not installed by me)?
Please help me understand what the issue might be and how I can fix it.

Could it be possible that the V4.3 code was built with a version of netcdf that uses compression for output, and that V4.2 was not? Take a look at any of the netcdf files (e.g., wrfout_d01*) and see if the file sizes differ between each time. If compression is used, the sizes will be slightly different from output time to output time. If it wasn't, file size should be identical for each output time. Compression can cause the model to run slower due to the time it takes to actually compress the files.
Thanks for sending those. Can you also send the namelist.input file that corresponds with each simulation, and I just want to see the sizes of files for each simulation. Can you go into the running directory for both versions and issue:

ls -ls >& log.4.2.txt

ls -ls >& log.4.3.txt

and attach both of those files, as well? Thanks!
Did you tried to turn off IEVA scheme on v4.3?

zadvect_implicit = 0,

Then see what happens; I suspect that is the reason for your observation.
I agree with Ivan. The namelist options aren't exactly the same. You are using different time steps (which you actually are using a larger one for V4.3, and would, in theory, speed that run up a bit), and you are using more vertical levels in the V4.3 run. You also have zadvect_implicit = 1 in the V4.3 simulation. Try setting that to 0 and see if that helps.

In that case I would look into compile.wrf file and check hardware optimization settings. Compiler choice, OPTAVX, CFLAGS_LOCAL, LDFLAGS_LOCAL ...
depending on how those are set up you might experience significant slowdown. But as you wrote you did not installed it, you might check that with your software administrator.

WRF needs to be recompiled if you find that compile.wrf needs changes.
So, I re-installed WRF 4.3 and it seems to be working fine now. Still no clue what went wrong with the previous installation though.