Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Run 2 domains in WRFV4.1 "File name that is causing troubles"

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

When I tried to run two domains in WRFV4.1, there were errors--" d02 2011-10-01_00:00:00 Error trying to read metadata
d02 2011-10-01_00:00:00 File name that is causing troubles ="

I saw a solution online that "use force_use_old_data=T in the time_control record of the namelist.input file"
After I add “force_use_old_data=1”, errors show:
" ------ ERROR while reading namelist time_control ------
Maybe here?: force_use_old_data=1
Maybe here?: /"

How can I solve this problem when running 2 domains in WRFV4.1?

Thanks in advance,

I suppose this is a real data case.Please let me know if I am wrong.
This error occurs when you run wrf.exe, is this right? Have you run real.exe successfully? Did you put wrfinput_d01 and wrfinput_d02 in your working directory?
Pease send me your namelist.input to take a look.
Hi Dr. Chen,
Thanks very much! I fixed it can WRF can successfully run now.
Yes, it is a real case. I didn't put d02 in my namelist.input by "input_from_file", so the run real.exe successfully run without d02 and I didn't realize that... Thank you so much for reminding me those possibilities so I can fix it, and I will remember to attach my namelist.input file next time for more convenience : )