Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

running 2D cases

NATARAJAN

New member
For my department presentation i have to run "2D flow over bell shaped hill". While i was configuring, we have to choose which compiler we need to compile our case . so i chosen 34(which is "dmpar"). after that another option pop out which is regarding to choose nesting option. in case of running 2D cases we need to choose no nesting option which is ("=0"). but in "dmpar" there is no option to choose zero value. i read wrf tutorial , they mentioned that we can choose option one("1=basic") it may allow to compile simple 2D cases. But it won't be work. still i was getting same error .even though i changed my WRF version it gave me the same configuration error. how can i overcome that dig? here i attached what is the error i got while compiling . according to that error i changed my case(3D- quarter super cell) , yes it works. but i have to compile my case.
 

Attachments

  • Screenshot from 2023-10-15 12-02-58.png
    Screenshot from 2023-10-15 12-02-58.png
    122.7 KB · Views: 4
Last edited:
Hi,
For 2D cases, you actually need to compile in serial (not dmpar), and then you will get the option for "no nesting" when you choose "serial" during configuration.
 
Thank you kwener sir ☺️ . According to your guidance i changed my configuration option as serial( =32) (GNU)gcc/gfortran compiler .Still i got an error . It showing that "problems building executable" then it mentioned that "look for error in the build log" even i couldn't found that text file. How can i overcome this problem.
Thank you!!.
 

Attachments

  • Screenshot from 2023-10-24 15-22-50.png
    Screenshot from 2023-10-24 15-22-50.png
    221.1 KB · Views: 2
i successfully run my 2D case by changing my WRFV.4.5.1 to WRFV4.3.3 . then i got an input and output file. Using post-processing tools i chosen ARWpost_V3, after untar it, i configured with gfortran compiler then i tried to compile it but i got an error even i tried two modification such as ( CPP=/lib/cpp -P -traditional and CPP =/lib/cpp -C -P -nostdinc) . here i have attached my configure.wrf and error file . thank you!!!
Note: my fortran version and ubuntu version.
GNU Fortran (Ubuntu 11.4.0-1ubuntu1~22.04) 11.4.0
Copyright (C) 2021 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 

Attachments

  • compilation error.txt
    5.7 KB · Views: 0
  • configure_wrf.txt
    1.7 KB · Views: 0
Last edited:
I'm glad to hear you were able to successfully run WRF. Since your new error is not related to the original error in this thread, please post the new issue as a new thread (specifically in the ARWpost section of the forum). Thanks!
 
Top