Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Segmentation Fault using UCM

einaraz

New member
Hi everyone,

I recently started running WRF on Cheyenne. To get started, I'm comparing the different urban physics models. I have a nested domain (9, 3, 1) km and I am using NARR and NLCD2011 for land cover. My three-day simulation finishes when I use Noah LSM + BEP or BEM. However, I keep running into errors when I try UCM (sf_urban_physics=1). The first issue was regarding the height of the first grid level, which seems to be solved after I increase dzbot. However, now my simulation crashes after a few hours (the time it crashes varies for 3-nested domain or single domain). I'm using almost all default settings, but I did try changing lw/sw schemes to no avail (I think the problem is related to the surface energy budget).
The details of my simulation and the rsl files are located here /glade/scratch/einaraz/WRFcomp/Simuls/NLCD2011-UCM
Do you have any suggestions to fix this problem?

Any help would be much appreciated!
Thank you!
 
Hi Ming,
Thank you for your reply. I attached here my namelist.input and wps, as well as the rsl file with the error message (rsl.error.0021).
 

Attachments

  • files.zip
    27.2 KB · Views: 10
Something in the physics went wrong in this case. In the rsl.error.0021, we can find some unreasonable value like:

f_qv=4294967295, f_qc=4294967295, f_qr=4294967295,

In your namelist.input, everything is fine except the option

use_wudapt_lcz

If you run with this option, then I suppose you should also use the wudapt urban land use type. I don't think this option works with NLCD.
 
Hi Ming,

I tried running the simulation without the option use_wudapt_lcz=1, and apparently it worked, thank you!

At first I was running the pre-compiled version available on Cheyenne (the most recent). I was first getting an error related to the VEGPARM.TBL, which I replaced after reading a similar question in the forum. After fixing that, I got the following error message

USING 10 WUDAPT LCZ WITHOUT URBPARM_LCZ.TBL. SET USE_WUDAPT_LCZ=1

That is why I changed that option. I would then get segmentation fault after a few hours of simulation.

When I run the same simulation using the code I compiled, I see no error messages and I am able to finish a three-day simulation using the UCM option. However, now I'm having issues when I try to activate the mosaic option (simulation here /glade/scratch/einaraz/WRFmycomp/WRF/run). I tried both NLCD 2006 and 2011 and the same problem happens, with the simulation stopping at minute 9 (same value as radt) without a specific error message. I was not able to find more information about the mosaic option in the user's guide, so I was wondering if the problem could be the combination of physics schemes or the data that I'm using.

Thank you!
 
The mosaic option is only used for diagnostic and it only works for Noah LSM. It is well tested with MODIS/USGS as input, and I am not sure whether there is any issues related to NLCD data.
 
Hello Ming and einaraz,

I got the same error with my SLUCM (sf_urban_physics=1) with LCZ and wudapt option set to 1., my dzbot is set at 50

01 2020-03-01_06:00:00 Input data is acceptable to use:
d01 2020-03-01_07:00:00 Input data is acceptable to use:
d01 2020-03-01_08:00:00 Input data is acceptable to use:

[sonic49:23280:0:23280] Caught signal 11 (Segmentation fault: address not mapped to object at address 0xfffffffe080755e0)

I have been on this without success for 2 months. However, I have got no issues with BEP and BEP+BEM. any clue will be greatly appreciated... my namelist.input is attached
 

Attachments

  • namelist.input
    5.5 KB · Views: 9
I am suspicious that the mosaic option may have some issues related to LANDUSEF, although I am not 100% sure. Please avoid using this option at present.
 
Hi everyone,

I just wanted to give an update on this issue.
I was able to finish the simulation using the same setup (NLCD data, UCM + mosaic) using an older version of WRF (v3.9.1.1). I haven't tried other versions, but it seems that the mosaic option has issues at least in the most recent version (v4.4).

Best,
 
Top