Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Segmentation fault

ClementS

New member
Hello all,
I have some issues with the run of WRF with nested domains : it seems to "crash" (or at least it stops working) and I don't have any solutions. I have no errors but only these segmentation faults :
"Caught signal 11 (Segmentation fault: address not mapped to object at address 0xfffffffe08e10a60)" and "forrtl: severe (174): SIGSEGV, segmentation fault occurred".

I have searched on the forum and tried different solutions that were given to people having the same issue :
- I reduced the time_step from 50 to 9. The time in simulation increased by a few minutes, but it still stopped.
- I changed the number of processors, I went from a large to a fewer amount (951, 512, 256, 128, 64,...) but it didn't changed anything.
- I also tried to increase the number of e_vert from 42 to 60. Like for the time_step, it was a bit better but it still stopped.

I am currently running a simulation with only my one domain and another with two domains and for now it seems to work. The thing that I don't understand is that I did some simulations last week with the same parameters and it worked perfectly. I only changed the size of the domains, and put history_interval from 0 to 5.

You will find attached the logs and my namelist (the segmentation faults are in the rsl.error.0096 and 0086). If anyone knows how to fix this, I will be very grateful.
Thank you in advance.
 

Attachments

  • namelist.input
    6.1 KB · Views: 6
  • rsl.tar.gz
    49.6 KB · Views: 3
Last edited:
Hi,
I am currently running a simulation with only my one domain and another with two domains and for now it seems to work.
Does this mean for the namelist you attached above, it works if you set max_dom=2, but not =3?

If you weren't receiving CFL errors initially, there is no need to reduce your time_step. I would recommend increasing that back to maybe 45. Otherwise your simulations are going to take much longer than necessary. Can you try that setting, and use 576 processors and see if that makes any difference. If not, can you try a different microphysics scheme to see if that helps?
 
Hello, thanks for you reply
Does this mean for the namelist you attached above, it works if you set max_dom=2, but not =3?
Yes I meant exactly that.

At the time of my first message I didn't received any CFL errors. However, I changed the size of the smallest domains and had some, but I don't really understand how the size of the domain can have an impact.
For now, using w_damping = 1 and increasing epssm seems to work no matter the size of the smallest domain, so I guess that in the end it had something to do with velocity. (I had to increase it to 0.4 for the size I have in the namelist of my first message, but it seems to have an impact on the quality of the results).

I'll try using other microphysics, I'll let you know if it worked out better.
 
Top