Setting first layer thickness

cross

Member
I tried to change de default 50m for the first layer to 20 m by using dzbot= 20 and keeping everything else default.
When I check the namelist.output seems ok, but when I check the vertical levels, are the same than the default setting.
Is there anything else I should set?
I'm using WRF 4.4

namelist.output:
Code:
 ETA_LEVELS      = 10001*-1.000000      ,
 AUTO_LEVELS_OPT =           2,
 MAX_DZ  =   1000.000    ,
 DZBOT   =   20.00000    ,
 DZSTRETCH_S     =   1.300000    ,
 DZSTRETCH_U     =   1.100000    ,

Vertical levels:
Code:
   Level         Sigma  Interface(m)     Center(m)
       0      1.000000          0.00
       1      0.993815         47.88         23.94
       2      0.985951        109.03         78.45
       3      0.976014        186.72        147.88
       4      0.963558        284.80        235.76
       5      0.948093        407.65        346.22
       6      0.929124        560.03        483.84
       7      0.906191        746.91        653.47
       8      0.878942        972.97        859.94
       9      0.847208       1242.03       1107.50
      10      0.811078       1556.40       1399.21
      11      0.770949       1916.48       1736.44
      12      0.727525       2320.88       2118.68
      13      0.681755       2766.35       2543.62
      14      0.634504       3250.19       3008.27
      15      0.586031       3776.02       3513.10
      16      0.536650       4347.64       4061.83
      17      0.486730       4968.71       4658.17
      18      0.440553       5588.70       5278.71
      19      0.398329       6200.84       5894.77
      20      0.359721       6805.27       6503.05
      21      0.324418       7402.22       7103.75
      22      0.292137       7991.88       7697.05
      23      0.262620       8574.13       8283.00
      24      0.235630       9148.50       8861.31
      25      0.210951       9714.81       9431.66
      26      0.188384      10273.83       9994.32
      27      0.167750      10826.71      10550.27
      28      0.148882      11372.11      11099.41
      29      0.131630      11911.92      11642.01
      30      0.115854      12448.66      12180.29
      31      0.101429      12988.32      12718.49
      32      0.088240      13535.88      13262.10
      33      0.076179      14089.83      13812.86
      34      0.065151      14646.44      14368.14
      35      0.055067      15203.61      14925.03
      36      0.045847      15760.60      15482.10
      37      0.037415      16317.69      16039.14
      38      0.029706      16875.21      16596.45
      39      0.022657      17432.72      17153.97
      40      0.016211      17989.58      17711.15
      41      0.010317      18545.16      18267.37
      42      0.004928      19098.98      18822.07
      43      0.000000      19650.95      19374.96
 

Ming Chen

Moderator
Staff member
Please remove the setting of eta_levels, then try again. Note that you also need to specify e_vert and p_top_requested.
 

cross

Member
Please remove the setting of eta_levels, then try again. Note that you also need to specify e_vert and p_top_requested.

Those eta levels are the calculated by wrf, I didn't specify it in the input file.
I have it configured like this:

Code:
e_vert                   = 44,       44,       44,       44,
p_top_requested          = 5000,
num_metgrid_levels       = 38,
num_metgrid_soil_levels  = 4,
dx                       = 9000,     3000,     1000,     500,
dy                       = 9000,     3000,     1000,     500,
grid_id                  = 1,        2,        3,        4,
parent_id                = 1,        1,        2,        3,
i_parent_start = 1, 29, 31, 23
j_parent_start = 1, 23, 29, 19
parent_grid_ratio        = 1,        3,        3,        2,
parent_time_step_ratio   = 1,        3,        3,        2,
feedback                 = 1,
smooth_option            = 0,
dzbot                    = 20,
 
Top