Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

SIGSEGV: Segmentation fault when running of wrf.exe

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

hoangnghiem72

New member
Hello,
We are running a 500 m resolution simulation in the WRF model version 4.2 for the small domain in the south Vietnam. When running the model, the pre-processing programs i.e. geogrid, ungrib, metgrid are performed successfully. The real.exe ran successfully but the error occurred on when running wrf.exe.

The error message is:

Timing for main: time 2018-11-23_04:59:59 on domain 2: 0.47232 elapsed seconds
Timing for main: time 2018-11-23_05:00:00 on domain 2: 0.49309 elapsed seconds
Timing for main: time 2018-11-23_05:00:00 on domain 1: 3.73472 elapsed seconds
mediation_integrate.G 1944 DATASET=HISTORY
mediation_integrate.G 1945 grid%id 1 grid%oid 2
Timing for Writing wrfout_d01_2018-11-23_05:00:00 for domain 1: 3.55346 elapsed seconds

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x7fa594b33d51 in ???
#1 0x7fa594b32f15 in ???
#2 0x7fa5947af6af in ???
#3 0x1ce2b15 in ???
#4 0x1d0644f in ???
#5 0x1d15402 in ???
#6 0x1788837 in ???
#7 0x1853acc in ???
#8 0x13a396d in ???
#9 0x12515af in ???
#10 0x46fd99 in ???
#11 0x405161 in ???
#12 0x404bec in ???
#13 0x7fa59479a1a2 in ???
#14 0x404c2d in ???
#15 0xffffffffffffffff in ???
Segmentation fault (core dumped)

Can you please advise how we can resolve this problem.
Thanks!
 
The error message you sent provides no helpful information. Please look at all your rsl files to find the possible error message messages.
In addition, please provide more information about this case:
The version of WRF
How you compile and run the model
The forcing data
namelist.input
 
Dear Ming Chen,

I compiled and run The WPS and WRF version 4.2 with gfortran and gcc on fedora 31.

The pre-processing programs such as geogrid, ungrib, metgrid are performed successfully, and the real.exe ran successfully. when I run wrf.exe the error occured at around five hours running. I can not find the rsl files. Please tell me where is it?

I used the NCEP GDAS Final Analysis ds083.3 with 0.25 degree for met input data to simulating the wind field for the period of 23 Oct 2018 to 27 Oc 2018.

The attached files below consists of namelist.wps, namelist.input, wrf.exe logfile.

Could you please advise me how to resolve this problem.
Thanks!
 

Attachments

  • wrf.exe.logfile.txt
    3.2 KB · Views: 90
  • namelist.wps
    1.8 KB · Views: 87
  • namelist.input
    4.4 KB · Views: 158
The settings for this case look unreasonable because:
(1) the grid number is only 56x56 for a parent domain with resolution of 3km. The forcing data is GFS at 0.25 degree resolution. Such a domain is too small for this case.
(2) The nesting ratio is better to be odd number. Please change 6 to 5 if possible.
(3) Time step can be at least 15s.

Please redesign the experiment and try again.
 
Dear Ming Chen,

I followed your advices and redesign my running with the parent domain grid number of 100cellx100 cell with resolution of 3km, the nesting ratio was 5 and the time step was 15s. Unfortunately, I got the similar error. Here I attach the namelist.wps, namelist.input, and wrf run logfile.
Please help me to overcome this problem. Thank you in advance.
 

Attachments

  • namelist.input
    4.4 KB · Views: 101
  • namelist.wps
    1.8 KB · Views: 76
  • wrf_run_logfile_error.txt
    9 KB · Views: 73
Again, I see some wring settings in this case. With grid intervals of 2.5km and 500m, cumulus scheme should be off, w_damping should be on, and RADT should be 2.5 instead of 30. You also need more vertical levels larger than 28.

I would suggest you start from a single domain run. Once the single domain case is done successfully, you can then move pn to nesting case.
Please also read WRF User's Guide and README.namelist to understand how to correctly choose the physics/dynamic options.
 
Dear Ming Chen,
I've faced the same trouble and got no direction for this problem.
Would you mind helping me resolve this one.
I'll give attachments with this message.
Detail below:
I ran: ungrib.exe; geogrid.exe; metgrid.exe and real.exe successfully, but when I wrf.exe, the model give me a short annoucement: "Segmentation fault"
I've read your advices upper, but the thing is that there's no log-file, error-file or something like that --> just rsl.error and rsl.out (but they're of real.exe - run <--- I've check 'em up by removing 'em, and then I ran real.exe again and see what's inside it, and then I ran wrf.exe and nothing changed inside those files ! - and there's no log-file or error-file added into the directory !)

More detail about the model:
Version: WRFV3.1.1
Linux version: Red Hat Enterprise Linux Server release 5.5 (Tikanga)

About my case-study:
2 domain with a nested one inside the rest with resolution of 27 kms and 09 kms, input data with the resolution of 1 degree (both latitude and longitude)
But when i met this error, i turned off the nested one (by editting: max_dom = 1) to check what happened.
Please help me get over this stuff <3
 

Attachments

  • namelist.input
    4.5 KB · Views: 46
  • namelist.wps
    739 bytes · Views: 34
  • rsl_error.txt
    12.4 KB · Views: 47
  • rsl_out.txt
    25.2 KB · Views: 44
Top