Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(SOLVED) Compiling error: /lib/cpp: No such file or directory

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

I have been using WRF version 4.1.4 but recently I am trying to use 3.9.1 version and I am getting error while compiling em real case.
I did not get this error before and I am compiling on a different machine and different version this time.
Hence, unfamiliar with the error.
I would appreciate any help solving the error. Attached are the configure and log.compile files.
NB All the system tests and library tests were successful and I am using intel compiler in dmapr mode.

View attachment log.compile
View attachment configure.wrf1.txt

Please help.
Hi Prerita,
The error I'm seeing in your compile log is:
/bin/sh: /lib/cpp: No such file or directory
make[3]: [Makefile:58: ESMF_Base.o] Error 127 (ignored)
which indicates that you either don't have a CPP library installed, or you aren't pointing to the right path for it. If you're not sure how to correct this, you'll need to check with a systems administrator at your institution for help resolving this. You may also find the information and steps in this compiling tutorial helpful.

I solved this issue and ran into another similar to this one here
The solution doesn't seem to work for me and I added a query in this post.
Could you please take a look at my question there and help me locate the issue.