Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Spatial artifacts in HGT_M in high-resolution domains

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I am using version 3.9.1 of WPS/geogrid and am trying to setup a 500-m grid-spacing domain across the US Midwest. Geogrid runs just fine, but the output has some kind of patterned artifact of bad values running through the grids, especially HGT_M, which causes problems when I get the wrfinput_d01 file from real and a subsequent WRF crash.

Here is the &geogrid section of my namelist:
parent_id = 1,
parent_grid_ratio = 1,
i_parent_start = 1,
j_parent_start = 1,
e_we = 2501,
e_sn = 1001,
geog_data_res = 'bnu_soil_30s+modis_15s_lakes+maxsnowalb_modis+albedo_modis+modis_lai',
dx = 500,
dy = 500,
map_proj = 'lambert',
ref_lat = 42.2,
ref_lon = -95.0,
truelat1 = 38.5,
truelat2 = 38.5,
stand_lon = -95.0,
geog_data_path = [omitted]
opt_geogrid_tbl_path = [omitted]
ref_x = 1250.0,
ref_y = 500.0,

Additionally, I ran some sensitivity tests to see how bad this behavior was. I used the exact same &geogrid namelist code as above, but varied dx/dy across the following range of values: 100, 500, 750, 900, 999, 1000. Screenshots of HGT_M for all but the 999-m run are attached. Depending on how you want to look at it, the problem either gets worse with ever decreasing dx, or the artifact seems to gradually fade as you approach 999 or 1000 m DX.

[*]DX = 1000 m: Those familiar with Midwestern US geography will recognize this as being centered roughly on Iowa.

[*]DX = 900 m

[*]DX = 750 m

[*]DX = 500 m

[*]DX = 100 m: Obviously, by the time I get this fine in grid spacing, the artifact dominates the field so badly that it's pretty much unrecognizable.
So what is going on here, and how do I eliminate this behavior?
I have been unable to repeat the problem, using your namelist setup - even down to 500 m. It looks like some of the static data you are requesting (modis_15s_lake, maxsnowalb_modis, and albedo_modis) are set-up in newer GEOGRID.TBL files (e.g., from V4.2). Are you using a newer GEOGRID.TBL to run geogrid? However, even when I do this, I still do not see the artifacts you see.

1) Have you made any modifications to the code?
2) What compiler are you using?
3) Just to verify - the plots you sent are from output, correct?
4) Are you running geogrid with multiple processors?
5) Have you tried a newer version of WPS (e.g., V4.2) to see if the problem still exists?
I have also not been able to reproduce the problem with a clean copy of the WPS v4.2 code. To add a couple of additional questions:

  1. Have you introduced a new default topography dataset, or are you using the 30" GMTED2010 dataset?
  2. Have you modified the interpolation options in the GEOGRID.TBL file?
I am using a data set that has likely been modified, and likely explains the artifacts.

I was able to find other means of solving the problem. Thank you for the replies.