Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Strange problem running ungrib


New member
Hi all,

I have what I think is a strange issue running ungrib (WPS within WRF v4.4.1; Intel compilers).
It may be a sysadmin thing on my side, but thought I'd post here as well.

I'm getting the error:
"ERROR: edition_num: unable to open GRIBFILE.AAA"
I get this error intermittently.
The grib files (ERA5, sfc and model level) read fine using g1print.exe.
The link_grib.csh seems to work fine as well. There are only two files in the directory being linked.
rm ${ingrib}/*
ln -s ${inmet}/ecmf_${sd}_an_sfc_0.grib1 ${ingrib}/
ln -s ${inmet}/ecmf_${ed}_an_sfc_0.grib1 ${ingrib}/
csh link_grib.csh ${ingrib}/ecmf_*

However, ungrib works sometimes and others not.
I run WPS within the WRF script and so a certain number of processors are available.
I thought this may have been a factor and reduced processors and it worked; albeit just for a single day and then error came back.
I can run ungrib.exe successfully within our login node, and if I get into one of the compute nodes.

Any ideas?
If I'm understanding correctly, are you attempting to run ungrib.exe with multiple processors? If so, that may be the issue. Even if WPS is compiled for parallel computation, the ungrib program is only capable of running with a single processor (serially) due to the way the code is written.