Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Strong non-smooth temperature pattern over snow/ice/water land categories

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.



I am running WRF version 4.1.3. and I noticed a strong non-smooth pattern e.g. for temperature for grid cells with the category snow/ice or water. Can you please tell me if such a strong pattern is to be expected? I would have thought that on boundary cells (cells with snow/ice/water close to cells with a different category) the effects would be adjusted.

- Temperature for the most inner domain (resolution of 40 m)
- Land use for the most inner domain (blue: water, white: snow/ice)

Thanks a lot!


  • WRF_lu_d05.jpeg
    35.7 KB · Views: 692
  • WRF_temp_d05.jpeg
    34.9 KB · Views: 693
Thanks for your help!

Please find attached the namelists. I have used hourly ERA5 data as input, as well as SRTM 1-arc topography data.


  • namelist.input
    4.9 KB · Views: 29
  • namelist.wps
    1 KB · Views: 36
Thanks for sending those. I see you're using sst_update. Are you using a separate SST input data than the ERA5 data? If so, is it possible that the landsea mask for the two data types is inconsistent? Otherwise, there is a particular process necessary for processing landsea for ERA5 data. Take a look at this forum post that describes the process. The post is for the MPAS model, but the input data processing is the same, so I believe you'll need to follow that same procedure.
Thanks a lot for the comments!

No, I am using SST input data from ERA5 downloaded via the CDS API, and the SST data is in the same .grib files than the other variables from ERA5. (As far as I understand, the forum post that you mentioned is for ERA5 data obtained through RDA or on the NCAR Glade filesystem.)

I attached a screenshot from ncview where I show the landsea mask (d01), as well as a screenshot from the SST from a random point, and both look fine to me. Moreover, I attached geogrid.log, ungrib.log and metgrid.log files.


  • Landsea.png
    39 KB · Views: 645
  • geogrid.log
    94.7 KB · Views: 24
  • metgrid.log
    26 MB · Views: 23
  • SST.png
    124.7 KB · Views: 645
  • ungrib.log
    875.4 KB · Views: 26
Thank you for your time!

I downloaded the invariant data file and included "constants_name = 'ERA5_INVARIANT" in the namelist.wps in the &metgrid section, but I get this error in metgrid.log (I have tried different runs, but I always get the same error):

2021-10-24 19:08:05.373 --- Read in static field OL4.
2021-10-24 19:08:05.374 --- Read in static field VAR_SSO.
2021-10-24 19:08:05.375 --- Getting input fields from ERA5_INVARIANT
2021-10-24 19:08:05.410 --- Processing LANDSEA at level 200100.000000.
2021-10-24 19:08:05.421 --- Processing SOILHGT at level 200100.000000.
2021-10-24 19:08:05.425 --- Preparing to process output time 2014-08-01_00
2021-10-24 19:08:05.425 --- Getting input fields from FILE
2021-10-24 19:08:05.432 --- ERROR: Cannot combine time-independent data with time-dependent data for field LANDSEA.mask

I was thinking that it could be because I included SST in the same grib files as my ERA5 data, so I tried to delete it from the Vtable (following this post with a slightly different problem, but I still tried it:, but it didn't help.
I apologize for the delay. I wanted to run this by a couple of my colleagues who are more familiar with the ERA5 data. They believe this is the behavior of the model because the landmask is derived from landuse data, not topography data. You are likely using higher resolution topography than 30', but likely with default landuse data. When you use 30s land use data (~ 1 km resolution) on a 40 m model grid, your landmask will look coarse.

One suggestion is to use SKINTEMP only (instead of SST)

Another option is to improve the interpolation of SST in metgrid, by changing the SST interp_option to the same as SKINTEMP uses in METGRID.TBL, i.e. from




The error you encountered when adding the ERA_INVARIANT file may be due to the fact that your original data already includes the LANDSEA field.