Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

time_step setting of high-resolution simulation

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


Dear Colleagues,

When I ran the high-resolution simulation, if I used the time_step suggested by the WRF guide: 6 × dx, the error information will be: time step too large.

For example: there are some time_step settings
domain3=250m, for nesting, 15s
domain3=4500m, for nesting, 300s
domain1=250m, for non-nesting, 50/6s
domain1=4500m, for non-nesting, 150s

But all of them cannot be run completely:
For nesting, I can use 3s as the time_step to run.
For non-nesting, following the WRF guide is fine, but longer time_step could not be utilised.

Could you please kindly explain the time_step setting in actual cases?

Best wishes,
I believe your math is off by a decimal place for the below. For e.g., for a dx=10,000, the recommended time_step setting would be 60s. So if you have a dx of 250m, the recommended setting would be 1.5s.
Dear Colleague,

For nesting, if I used the time_step suggested by the WRF guide: 6 × dx, the error information will be: time step too large. But I can use 3s as the time_step to run:
For non-nesting, following the WRF guide is fine.

Could you please kindly explain the time_step setting issue above?

Best wishes,
The time_step is chosen for only the parent domain. The model then assigns a time_step to the children domain using the parent_time_step_ratio. Without seeing your namelist settings, I'm not sure what your full set-up is. If you're still confused, please attach your namelist.input file so I can take a look. Thanks.
Dear Colleagues,

Please find the namelist.input for nesting and non-nesting cases in the attached files.

Best wishes,


  • domain1=4500m.input
    3.6 KB · Views: 31
  • domain3=4500m.input
    4.2 KB · Views: 26
For your nested namelist, the resolution of domain 1 is 40500, meaning you should be able to use a time_step of 243 without problems (unless the domain is over complex terrain, which you would then need to lower it, but definitely not down to 3!). Can you attach the full error log when you are getting an error regarding the time_step being too large?

A couple of other points:
1) What is the resolution of your input data (from the outside model - first-guess data)?
2) The size of your domains is entirely too small. We don't recommend domain size (e_we and e_sn) to be any smaller than 100x100 to provide reasonable results.
Dear Colleague,

Please find the attached files.

Input data resolution: 31km
domain size (e_we and e_sn)=100x100: indicates the coarest level domain or all the domains?

Best wishes,


  • rsl.error.txt
    1.9 KB · Views: 11
  • rsl.out.txt
    1.8 KB · Views: 5
This error says that your time_step is set to 300.
 D01: Time step                              =    300.000000      (s)
 D01: Grid Distance                          =    40.5000000      (km)
 D01: Grid Distance Ratio dt/dx              =    7.40740728      (s/km)
 D01: Ratio Including Maximum Map Factor     =    7.33465385      (s/km)
 D01: NML defined reasonable_time_step_ratio =    6.00000000
The time step is probably too large for this grid distance, reduce it.
 If you are sure of your settings, set reasonable_time_step_ratio in namelist.input >    7.33465385
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:     339
--- ERROR: Time step too large
The namelist you sent has it set to 3, so this must not be the namelist version that goes with the error message.

Additionally, if you are using input data with a resolution of 31km, there is no need to have an outer domain that is even more coarse (40.5km) than that. You should be able to run only 2 domains (dx = 13500, 4500) with no problems. If you do this, your time_step should be less than or equal to ~80.

The recommendation of AT LEAST 100x100 is for all domains.
Dear Colleague,

Many thanks for your reply. The error files I attached are with time_step=300s, because with this time_step, I got the running error. But for time_step=3s, the error files are attached below with its namelist files, and this running is complete.

Setting all the domain sizes (e_we and e_sn) more than 100x100 are very difficult to achieve, because my input data contains limited area. Do you have any suggestions for solving this issue?

Best wishes,


  • namelist.input
    4.2 KB · Views: 30
  • namelist.wps
    1.7 KB · Views: 13
  • rsl.error.txt
    120.2 MB · Views: 7
  • rsl.out.txt
    120.2 MB · Views: 8
I'm glad to hear the simulation is running with a lower time step.

As for the domain size, as I mentioned above, you do not need the outer domain with a grid resolution of 40.5 km. If you use that same area, but use a higher resolution there, you will be able to have a somewhat larger domain. An alternative is to use a different input dataset.