Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Too many input soil types

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


Wrf is crashing with the following: Warning: too many input soil types
It runs for domain 1 but crashes in domain 2 and 3.
Someone kindly help.
Please provide more information about this failed case:
(1) Input data
(2) WRF version
(3) namelist.wps and namelist.input
(4) Does real.exe work fine?
The input data include the static data processed by WPS and the large-scale forcing data that provides initial and boundary conditions for WRF run.
soil types are derived from static input data. Unless you changed the static data, I see no reason why the soil type could be an issue.
1. For the static data I am using the default WRF data. Only change was with the landuse in which I used modis 15s with lakes.
I am using ERA5 meteorology for IC/BC which I got from ECMWF and not from NCAR archive.
2. WRF Version 4.1.2
3. Attached
4. Yes real.exe works.

The error occurs in the smallest nested domain and not in the larger domains. If I use 3 domains, it ll occur in domain 3 or domain 2 if I use 2 domains.
Update: Replaced the wrong namelist.input


  • namelist.wps
    1.6 KB · Views: 62
  • namelist.input
    8.3 KB · Views: 62
Is there any update regarding the issue?
The model is running with an increased grid size, but I wonder what may have been the issue.
Your namelist.wps and namelist.input both look fine.I am puzzled why the soil type could be wrong. If you run the case in cheyenne, would you please tell me where your met_em and wrfinput files are located?
Another option is, can you download ERA5 data from CISL RDA, then rerun the case and see whether wrf.exe works? I am suspicious that the data from ECMWF website may have some issues, although I am not sure what it could be.
Unfortunately, I am not using Cheyenne.
A thing I had forgot to mention. I had tried with NCEP-FNL 1 degree after failing with ERA5, I had got the same error. I had to change the sf_sfclay_physics option to 91 to get over that error.
I am working on a fairly complex terrain at 2 km resolution. Could that be a reason?

The ERA5 data in the RDA archive does not allow domain sub setting leading to huge download files, due to which I had to use data from ECMWF. I will try it if time permits.