Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

troubles, could not find trapping x locations

Sunwx

New member
I am using WRF version 3.6.1. And I tried to set the p_top_requested to 5000, and it doesn't change the result.

The error I'm getting is:
Using sfcprs to compute psfc
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 5401
troubles, could not find trapping x locations
-------------------------------------------
application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=1
:
system msg for write_line failure : Bad file descriptor

I am attaching my namelist.input and error file.
Could you please help me with this?
Thanks,
Joy
 

Attachments

  • namelist.input
    8.8 KB · Views: 4
  • rsl.error.0000
    341.9 KB · Views: 2
Hi,
What type of input data are you using? Are you making sure to process both the 3D atmospheric data, as well as the surface fields? This error can sometimes occur when the met_em* files are missing data, and sometimes it's just missing the data in the upper levels. Check your files to make sure you're not missing anything.

Another thing I notice is that you are using a resolution of 180 km. Is that really your intention? Most input data are available in no more coarse than about 1 degree, which would mean your domain would not need to be more coarse than about 30 km. I'm not sure if this could be causing any of the issues, but you are not going to be able to resolve much of anything with 180 km grid spacing.
 
Thank you!
I find that the datas don't be decoded by the ungrib.exe when I first encounter this preblem. But now i correct. When i run the real.exe, I also have the same problem. The new rsl.error.0000 is attached.
The data I used is created by myself. And i make sure to process both the 3D atmospheric data and the suface atmospheric data.
Thanks!
Joy
 

Attachments

  • rsl.error.0000
    1.9 KB · Views: 5
Top