Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

unable to compile WPS using Cray machine


New member
Hi, forum,
I am not able to compile WPS with grib2 after successfully compiling WRF using a Cray machine.
This is the error I get:
/opt/cray/pe/cce/9.1.1/binutils/x86_64/x86_64-pc-linux-gnu/bin/ld: cannot find -ljasper
/opt/cray/pe/cce/9.1.1/binutils/x86_64/x86_64-pc-linux-gnu/bin/ld: cannot find -lpng
make[1]: [Makefile:19: ungrib.exe] Error 1 (ignored)

I already set my JASPERLIB and JASPERINC environmental variables so not really sure what other things I can check to debug this error. I attach my full compile wps log file here.
echo $JASPERLIB /usr/lib64
echo $JASPERINC /usr/include
I set those variables because the sys admin told me the rpm packages are there.



  • compile_log_wps.txt
    7.5 KB · Views: 3
Thank you for sending those. In your configure.wps files, you have the following setting:
COMPRESSION_LIBS    = -L/usr/lib64 -ljasper -lpng -lz
COMPRESSION_INC     = -I/usr/include

But the compile log is showing that it's looking for those jasper and PNG libraries in

So it seems that they may be an environment setting that is overriding the configuration paths and looking for the libraries elsewhere. Is it possible that you logged out of your terminal window in between running the configure and the compile for WPS, so that the paths you set were no longer active? I would advise checking your environment to see if you can figure out why it's looking in the other path. In addition to JASPERLIB and JASPERINC, check settings for LD_LIBRARY_PATH.

Another, perhaps simpler, solution would be to use the method released with WPSV4.4 to automatically compile the grib2 libraries with your build of WPS. Take a look at this previous thread. See my post from 3/13, in which I describe how to do this.
Hi Kelly,
I did not log out of my terminal window in between running the configure and compile for WPS. The paths seem to be active so I sent an email to the system admin to see if there is something going on overriding the environmental variables. Now, when I type $LD_LIBRARY_PATH this is what I get:
"bash: /sw/gaea-cle7/darshan/3.2.1-1/runtime/lib:/sw/gaea-cle7/uasw/ncrc/envs/20200417/opt/linux-sles15-x86_64/gcc-7.5.0/globus-toolkit-6.0.17-klqyvmmhxqsf77ita7vvlw3wgyire7df/lib:/opt/cray/pe/papi/ No such file or directory"
So maybe something is wrong in there?

I will try version 4.4 since I am using version 4.3.
Update, I tried with version 4.4 and I could create ungrib.exe but I got the following error:

/opt/cray/pe/cce/9.1.1/binutils/x86_64/x86_64-pc-linux-gnu/bin/ld: /opt/cray/pe/hdf5/ in function `H5PL__open':
/ptmp/tmp/bavier/BUILD/hdf5-1.10.5/src/H5PLint.c:326: warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking /opt/cray/pe/cce/9.1.1/binutils/x86_64/x86_64-pc-linux-gnu/bin/ld: read_met_module.o:(.data+0x2408): undefined reference to `met_data_module_' make[1]: [Makefile:76: int2nc.exe] Error 1 (ignored)

Thanks a lot,
Last edited:

Is that error part of your WPS compile log? Can you attach the full log, along with your new configure.wps file? Were all three executables created?
Hi Kelly,
Just wanted to close this post. I tried compiling WPS using version 4.4 compiling the grib2 libraries with my build of WPS and it worked.