Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Unable to compile WRF with intel compiler

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I have made a first successfull installation of WRF4.0 by following step by step the tutorial here :
Compilation and run time were both OK, with the GNU compiler as stated in the above link. I have chosen the option 34 in the WRF configure script.
I have attached the small script that I have made in order to set all the variables for the compilation/installation of the system. The file is called setEnvForWRF.
I wanted to improve the performances with the intel compiler and here came the troubles.
First, I have changed the environment variables to use the intel compiler, the attached script to do that is named setEnvForWRF_intel.
Then I have deleted all the libraries netcdf, zlib... and unpacked once again, in order to be sure that nothing existed from the previous GNU installation.
I have made all the small tests requested in the tutorial and all was OK.
I have re-compiled everything, netcdf, zlib...etc (as explained in the link of the tutorial mentioned above). The compilation was successful and also all the 'make check' commands were OK. So everything was fine. Now, I go to the WRF directory and type ./clean to remove the previous installation.
I chose option 66 in the WRF configure script.
Then, at compilation, I get a bunch of compilation errors, as shown in the compile log file.

Thanks a lot for your help !

----------------------------------System INFO--------------------
Intel i7 8086K 6 cores
gcc = 4.8.5
ifort =

WRF 4.0


  • setEnvForWRF_intel.txt
    450 bytes · Views: 97
  • setEnvForWRF.txt
    455 bytes · Views: 85
  • log.compile.txt
    1.5 MB · Views: 76
Can you compile this with only 1 processor - this just helps when looking through the compile log, so that we know that the first error we see is THE problem. To do this, you'll need to issue another 'clean -a' and then set to 1 processor with:

export J="-j 1"

Then reconfigure and recompile. I still expect the compile to fail, so once that is done, please send the new compile log and your configure.wrf file.

Thanks a lot for your quick answer.
Now it works !! WRF and WPS compile well with intel compiler !
What has changed ?

When I read your answer saying to type 'clean -a' , I have realized that I have only typed clean, without '-a'. I have made quite a lot of unsuccessful trials before. So, by typing 'clean -a' it seems to have removed all the previous wrong files

I hope this does not hide another problem. But so far, I will try the run time now.
Anyway, your answer was very usefull, otherwise I would have never had the idea to type in the right command option.

That is great that you were able to get past the compiling problem! Sometimes machines can be weird - as you said, there may have been some settings or files that were built already and causing the problem, and simply cleaning the code solved that. Regardless, I'm glad you're able to move on. Thank you for letting me know.