Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

unable to create .exe file while compiling the test case

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.



i am using WRF 4,0
i am facing problem while compiling the test case. (real_em) when the compilation is completed the four .exe file was not created.
The compile.log and configure.wrf is attached below.
instead to compile with gfortran i am using ifort.

Has anyone else had this problem?


  • configure.wrf
    20.1 KB · Views: 44
  • compile.log
    2.1 KB · Views: 47
Inside your compile log, you should be able to find this message near the top:
The em_squall2d_x case requires a build for only single domain.
The em_squall2d_x case cannot be used on distributed memory parallel systems.
Only 3D WRF cases will run with the options that you selected.
Please choose a different case, or rerun configure and choose a different set of options.

If you are trying to build any of the 2D cases, you must compile serially (i.e., not using dmpar) and with a no-nest option (option 0).

hi, i am installing wrf in server all the libraries are install in (/usr/local/LDT_install), please take a look in my bashrc file i am unable to create an .exe file, mpich file was also install in same directory. i am also try to comment these NETCDF_LIB and NETCDF_INC but same problem is facing .
one more question i want to ask, is the version of these libraries will effect while compiling WRF

i am using libpng 1.6.36
mpich 3.0.4
netcdf 4.1.3
zlib 1.2.7
jasper 1.900.1

please help

export CC=gcc
export CXX=g++
export FC=gfortran
export FCFLAGS=-m64
export F77=gfortran
export FFLAGS=-m64
export PATH=/usr/local/LDT_install/bin:$PATH
export NETCDF=/usr/local/LDT_install
export NETCDF_LIB=/usr/local/LDT_install/lib
export NETCDF_INC=/usr/local/LDT_install/include
export LDFLAGS=-L/usr/local/LDT_install/lib
export CPPFLAGS=-I/usr/local/LDT_install/include
export JASPERLIB=/usr/local/LDT_install/lib
export JASPERINC=/usr/local/LDT_install/include
export PATH=/usr/local/LDT_install/bin:$PATH
export NETCDF_classic=1
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/LDT_install/
If you are following our compilation tutorial website:
then you should set your environment variables exactly as is indicated there. A few problems I notice with the bashrc settings you've listed are:

1) export NETCDF=/usr/local/LDT_install
This should likely be set to
export NETCDF=/usr/local/LDT_install/netcdf

2) You shouldn't need to set NETCDF_LIB or NETCDF_INC in your environment script

3) export JASPERLIB=/usr/local/LDT_install/lib
export JASPERINC=/usr/local/LDT_install/include
These should likely be
export JASPERLIB=/usr/local/LDT_install/grib2/lib
export JASPERINC=/usr/local/LDT_install/grib2/include

The versions of the libraries you are using should be okay. I would suggest starting from a new clean slate and going through the compilation tutorial from the beginning and trying to install everything exactly as is indicated, making sure to set your paths the same as the web page says. If you are still getting failures, then please attach your new configure.wrf, your modified bashrc file, and your compile log (please attach these instead of using the copy/paste function).