Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ungrib.exe error: "Field = TT in WRF 3.9.1"


New member
I am facing error "ERROR: hdate = 2019-06-12_09:00:00.0000 , fuldates = 2019-06-12_06:00:00.0000 2019-06-12_12:00:00.0000, Field = TT" while running ungrib.exe for the year 2019. I tried to run it with an ungrib.exe file from WRF.4.4 as (solution mentioned in one of the threads in the forum) but hard luck.

If I run it up to 2019-06-11 then it's running successfully.

Any help will be highly appreciated.

Thanks and Regards,
GFS data structure has been changed a few times in the past years. This might be an issue involved in your case.
Can you compare the data before 2019-06-11 and that after 2019-06-11? I guess they should be different. Usually newer version of WPS can handle updated GFS data, but it seems that this doesn't work for you. Can you tell where you download GFS data?
Yes, I checked the format with cdo, and it's the same. is there any other way to check the difference? I am not sure whether, to use only ungrib.exe from 4.4. version or all .exe from WPS's newer version? Can you please confirm?
Data has been downloaded from NCAR RDA Dataset ds083.2.

NCAR RDA Dataset ds083.2. saves FNl data at 6-hr intervals.

I download 4 files, fnl_20190612_00_00.grib2, fnl_20190612_06_00.grib2, fnl_20190612_12_00.grib2 , and FNL:2019-06-12_18 , run ungrib.exe to process these 4 files.

ungrib.exe runs successfully. Note that I use Vtable.GFS and run WPSv4.2

Please try again and let me know if you still have problem.
Hi Chen,
I retried with newer version 4.4, it is showing the new below error now. Ungrib.log and namelist.wps is attached.
*** Starting program ungrib.exe ***
Start_date = 2019-06-10_00:00:00 , End_date = 2019-06-15_18:00:00
output format is WPS
Path to intermediate files is ./
ERROR: Grib2 file or date problem, stopping in edition_num.


  • namelist.wps
    746 bytes · Views: 2
  • ungrib.log
    652 bytes · Views: 1
Have you linked the FNL data to GRIB files, then run ungrib.exe?
Also, please make sure you use Vtable.GFS.

I don't think WPS has any problem to process FNl data. The problem you have is really weird.
Sorry for the late response.

Now I have also tried version 4.2. But still, it is not working, same error.

Yes, I have linked FNL data and used Vtable.GFS with the following commands.

./link_grib.csh /../../../WPS_FNL_GEOG/FNL_2019/ .
ln -sf /../../../WPS_FNL_GEOG/FNL_2019/fnl* .
ln -sf ungrib/Variable_Tables/Vtable.GFS .
Suppose your FNL data are saved at ../../../WPS_FNL_GEOG/FNL_2019/, and you are in the WPS directory, please issue the following two commands:
(1) ./link_grib.csh ../../../WPS_FNL_GEOG/FNL_2019/*
(2) ln -sf ungrib/Variable_Tables/Vtable.GFS Vtable
Then you can run ungrib.exe.
Done, but still, it shows the same error.
*** Starting program ungrib.exe ***
Start_date = 2019-06-11_18:00:00 , End_date = 2019-06-13_18:00:00
output format is WPS
Path to intermediate files is ./
ERROR: Grib2 file or date problem, stopping in edition_num.
I am really perplexed by your issue....
I did a test to process the FNL data and there is no problem at all.
Sorry that I have no idea what is going on on your side....