Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ungrib v4 segmentation fault: when using 0.25 degree grib2 data for 2018

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I have recently faced a problem with my WPS runs. I use WPS-4.1 and I need to run it for the summer of 2018. However, when I use the 0.25 degree grib2 data files from (NCEP GDAS Final Analysis ), and I run 'ungrib.exe', it seems like it creates PFILES and in the end I get an error message saying:

"Name of source model =>NCEP GFS Analysis
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
ungrib.exe 00000000004B06BD Unknown Unknown Unknown
libpthread-2.17.s 00007F2561A5B5E0 Unknown Unknown Unknown
ungrib.exe 000000000041FB15 Unknown Unknown Unknown
ungrib.exe 000000000040AEBD Unknown Unknown Unknown
ungrib.exe 00000000004039BE Unknown Unknown Unknown 00007F25616AAC05 __libc_start_main Unknown Unknown
ungrib.exe 00000000004038C3 Unknown Unknown Unknown"

I solved this problem by using a different Vtable that I found online (I attached the Vtable to this email). However I am not sure if this is the right way to deal with it.

Does anybody know if this is the solution?

Thank you all,


  • VtableText.txt
    3.8 KB · Views: 109
Can you give me more information about the NCEP GDAS final analysis? Where did you download this data? Did you create Vtable to ungrib it?
Thanks for getting back to me.

I download the data from NCAR RDA (Research Data Archive):
There are analysis data and forecast data. I only downloaded "*.f00.grib2" which are analysis data.

I usually use the "Vtable.GFS" that exists in '/WPS/ungrib/Variable_Tables/" folder which I have attached to this message. When using "Vtable.GFS", I get the segmentation fault error.

However, I found "Vtable.GFSPARA" online as a solution. I attached that to this message as well. With "Vtable.GFSPARA", ungrib seems to run successfully. It however doesn't seem to include everything as in Vtable for GFS pressure-level data from the ncep server (Vtable.GFS) and that is why I am not sure if it could be the right solution.


  • Vtable_GFS.txt
    8.4 KB · Views: 75
  • Vtable_GFSPARA.txt
    3.8 KB · Views: 108
I looked at the GDAS data downloaded from RDA ds083.3. It includes all variables required for running WPS/WRF.
I believe it should work if your Vtable, which I didn't check all details, is correct.
Please try and let me know if there is any problem.

I ran into this same problem with WPS4.1.3 compiled with intel 19.0.5. The 0.25 degree came from the same download site.

The code and data works fine when compiled with intel 18.0.3 on another system.

Please advise.

I am having the same error, as I am using the same data set and Vtable as the original post. Here is my namelist.wps and my ungrib.log.

Is there anyway to get a more descriptive error message from ungrib?


  • namelist.wps
    1.3 KB · Views: 64
  • ungrib.log
    68.1 KB · Views: 77
I wasn't able to get a better error message, but I was able to allocate more stack space and run ungrib again (ulimit -s unlimited). When I re-ran following this change, everything worked.