Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Using High Resolution Static Land Data SRTM for the nests - How to set up Namelist.input

ashaygan

New member
Hi all,

I am using SRTM static data for the nests in the WPS program.
ungrib, geogrid and metgrid programs run successfully.
The process is successful and metgrid files are made showing topology (HGT_M) taken correctly from the SRTM dataset.
However, WRF output files seem to have used the coarse topology data, instead of the high resolution data, even though correct metgrid files are made and linked.
I was wondering if someone knows the root of this issue.


I am using 3 domains, 1 parent, two nests.
Can it be because of the option input_from _file which is set to true just for the first domain?
input_from_file = True., .False., .False.,
When I set all to true, the simulation breaks!


I appreciate any helpful comment on this.
 
Hi,
Yes, that is exactly why. Because you have domains 2 and 3 set to false, the model is only using met_em* data for d01 and then interpolating it's data to the nested domains.

input_from_file = True., .False., .False.,
When I set all to true, the simulation breaks!
Can you provide more detail about this? Please package all of your rsl* files into a single *.tar file and attach that. Thanks!
 
Hi K,

Thanks for your response.
The RSL.tar includes all rsl files, attached.
The Other.tar includes the namelist.input and a sample job script, attached.

I set the simulation to run on a high number of CPUs. To make things simpler, attached is a sample job for 20 CPUs which gives similar rls files and error.
I tried it for high number of CPUs (1500 and higher), the errors are similar.

Please let me know if additional information is require.
Thanks a lot.


Bests,
A.
 

Attachments

  • RSL.tar
    660 KB · Views: 1
  • Other.tar
    10 KB · Views: 1
Thanks for sharing those. Can you let me know what type of meteorological input data you're using, and what is the resolution of those data?

I also see that you have the following set in your namelist.
e_vert = 50, 80, 150,
vert_refine_method = 0, 2, 2,

Can you first try to do the simulation without using vertical nesting to see if you're able to run (i.e., try setting e_vert to 50, 50, 50)? And when you do, try only 2 domains to begin with. When you're using several different options at one time, it can be difficult to nail down the culprit causing the issue, so it helps to try to make everything as simple as possible and then slowly add more options to see which one breaks the model.

I know that you said you used only 20 processors and then also tried up to 1500. Can you try using around 800 for the new tests? Thanks.
 
Hi K,

Thanks for your help. Simulation failed again. I used equal vertical levels, and 800 CPUs, each 8G memory.
Unfortunately there is a limit to the file I can upload here, so I just included 101*2 rsl error and out files.
The namelist.input that I used is included too.
I forgot to use only 2 domains. It is still using 3. If the information is not sufficient to nail down the causing error, I can try 2 domains too.
However, I am using the SRTM for the third domain (second nest, finest domain). A small part of the first nest is using SRTM, the rest of it is using coarse topology data (close to the parent, using coarse, and close to the inner nest using SRTM. The wps program is set to prioritize the SRTM data.)

The atmospheric data comes from standard high resolution HRRR (3km and 1hour resolution).

Bests,
A
 

Attachments

  • Other.tar
    1.5 MB · Views: 1
Apologies for the delay. Thanks for trying that out. I would like to see if I'm able to reproduce your issue here. Can you share your wrfbdy_d01 and wrfinput* files with me? These are almost certainly going to be too large to attach, so take a look at the home page of this forum for instructions on sharing large files. Will you also please share your namelist.wps file so I can see exactly where your domains are? Thanks!
 
Hi, thanks for your assistance and time. namelist.wps is attached here. The wrfbdy_d01 file was uploaded with the name "bdy.tar".
Thank you very much.
Bests,
A
 

Attachments

  • namelist.wps
    1.4 KB · Views: 1
Last edited:
Hi,
Can you please also share your wrfinput_d01, wrfinput_d02, and wrfinput_d03 files? Thanks.
 
Top