Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Using WRF Portal ungrib stops with no error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello guys,
I was having problem with ungrib, but it was with the data, so i solved it and my WRF worked perfectly. I already plotted the outputs on GrAds!

Unfortunatelly, i needed to run WRF again (cuz i now i need a bigger grid). I used the same namelist as in the first run and it didn't work! I am using WRF PORTAL (wizard) to do the geogrid, ungrib and metgrid because i am new and i think it's more friendly!

So Here is my new problem:
My geogrid works fine, but when i do the ungrib, it just stops in a randonlly date. There is not a message of error, the ungrib just frozen in a random prognostic.

The only thing that appears is:

Contents of /home/lammoc/DUDA/dominios_duda/new_grid/ungrib.log (see the attachment)

So i am not understanding what is going on! Because there isn't an error message, just this "content" text that show where my log is located!

Can someone help me?

First I would like to note that if you are planning to use the same input data with the same resolution, dates, etc. it shouldn't be necessary to run ungrib again, as you only need to de-grib the data once, even if your domain is being modified (unless the data only cover a subset of the Earth and do not cover the new domain completely).

Unfortunately our group doesn't develop/support the domain wizard, so it's hard to determine what may be going on. If you determine that you actually do need to re-run ungrib, can you try to run it without using the wizard (i.e., just from the command line in a terminal window)? Could it possibly be that you have filled up your disk space where this directory resides and that because of the previous files, there is no room to write more files here? If you try to run this without the domain wizard and are still having problems, please attach the following: namelist.wps, ungrib.log, and let me know which version of WPS you are running, and what type of input data.