Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF and tracers

llsalazardom

New member
Hello,
I want to run WRF with tracer, I added the variable tracer_opt=2 to my namelist.input but I get the error 'Segmentation fault'. I read some indication that I need to edit the files Registry.EM, module_initialize_real.F and solve_em.F and then go back to compile the model, is this correct? Is there a recommended guide for summing with tracers?

Thank you
 
Hi,
If you run this same case without setting tracer_opt = 2, does it run to completion? If you still get a seg-fault, it may not be due to the tracer setting. Let me know the answer to that, and then please attach your namelist.input file, as well as all of the error files - for e.g., if you have several rsl.error* files, please package those into a single *.tar file and attach that, as well. Thanks!
 
Hello

Thanks for your reply

Yes, if I run this case without setting tracer_opt=2, it runs to completion successfully.

I attach my namelist* and rsl.error* files
 

Attachments

  • namelist.input
    5 KB · Views: 3
  • namelist.wps
    1.4 KB · Views: 1
  • rsl.error.tar.gz
    3.9 KB · Views: 1
Thanks for sending those. I notice that you are also running wrf-chem. Can you let me know if you're able to run this with the tracer_opt turned on with a basic WRF simulation (i.e., code compiled without using wrf-chem)? If so, then we know this is likely specifically related to WRF-Chem, and you will need to post your question in the WRF-Chem section of this forum. If it still fails, then we will have at least ruled out the possibility that it's only related to chemistry.

A couple other suggestions:
1. Your domains are too small. You have the following settings:
Code:
e_we        = 59,          49,          37,
 e_sn                    = 47,          37,          25,

Each domain should not be smaller than 100x100 to provide realistic results.

2. Your time_step is a value that is not evenly divisible by seconds, minutes, or hours. This can cause issues with outputs and output times sometimes. I would recommend setting it to something more like 120.
 
Good morning @kwerner

Thank you for your reply

I have fallowed your advice. I created other test with domains with more grid points and ran it in WRF without Chem and this ran successful. Now I'm going to analyze the results but the problem is solved. Thank you so much.

On the other hand, if I run some test without a tracer on my WRF-Chem installation, this test runs successfully, the problem appears when I use tracers, Can't run tracers in WRF-Chem setup?
 
I'm glad to hear that you made some progress! If you are wanting to use tracers with wrf-chem, I would suggest posting in the wrf-chem section of this forum to see if they can help you. Unfortunately our group does not manage or develop wrf-chem.
 
Top