Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF compilation error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

While compiling wrf in (dm+sm) mode I got error while earlier I was able to compile sucessfully. But due to some problem I need to recompile WRF
I have attached the log file and configure file below.
I have set my environment variable
export DIR=/home/jayanti/WRF/Build_WRF/LIBRARIES
export CC=gcc
export CXX=g++
export FC=gfortran
export FCFLAGS=-m64
export F77=gfortran
export FFLAGS=-m64
export JASPERLIB=$DIR/grib2/lib
export JASPERINC=$DIR/grib2/include
export LDFLAGS=-L$DIR/grib2/lib
export CPPFLAGS=-I$DIR/grib2/include
export PATH=$DIR/netcdf/bin:$PATH
export NETCDF=$DIR/netcdf
export PATH=$DIR/mpich/bin:$PATH

!!version of gfortran!!
gfortran --version
GNU Fortran (Ubuntu 5.4.0-6ubuntu1~16.04.12) 5.4.0 20160609
Copyright (C) 2015 Free Software Foundation, Inc.


  • configure.wrf
    20.1 KB · Views: 50
  • log.compile
    602.4 KB · Views: 69
The error message indicates hat the file doesn't exist. However, this file should be automatically generated during the compiling process. Failing to generate this file often indicates something wrong in the environmental settings or libraries required for building WRF. The 'dm+sm' mode makes this more complicated to figure out the reason.

Is there any special reason that you need to compile in dm+sm mode? If possible, I would suggest you build the code in dmpar mode.
I just tried to build WRFv4.0 in my computer, using the dm+sm mode. And the code is complied successfully.
thank you for your reply. I have sorted out this problem. mpi library was installed in usr/bin where it was set wrongly. I correct it and compiled it