Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF compile doesn't make .exe files

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Mozzarella

New member
Dear all

I am new in WRF software. I am trying to install WRF and WPS in linux(CentOS 8.4 64 bit).I have succesfully installed jasper-1.900.1, libpng-1.2.50, zlib-1.2.7, netcdf-4.1.3, and mpich-3.0.4.

I have been guiding myself for the installation with the UCAR guide (https://www2.mmm.ucar.edu/wrf/OnLineTut ... torial.php).

The problem ocurrs during compilation of WRF after the configure process. The compilation process run, and run for about 8 minutes, but I don't get the executables. The log compile file have the next message:

---> Problems building executables, look for errors in the build log <---

These is my log file and config.
View attachment configure.wrf
View attachment log.compile
can you help me?
Thank you in advance!
 
Hi,
If you search for the word "Error," (with a capital "E"), you will see the error is related to the module_state_description file. Can you try to compile the latest version of the code to see if you are still receiving the same error? Thanks!
 
Dear Kwerner,
Thank you for your reply.
As per your suggestion, I have created the configure and logfile again.

Thank you very much for your help
 

Attachments

  • 20220301configure.wrf
    20.1 KB · Views: 20
  • 20220301log.compile
    852.7 KB · Views: 18
Hi,
It looks like you compiled WRFV4.0 again. Can you please try to compile with the latest version of WRF (V4.3.3) to see if there is any difference? Thanks!
 
Hi,
Thank you for your advice. I downloaded the latest version of WRF(v4.3.3) and compiled it.
There was such a warning when I configured it.
"The moving nest option is not available due to missing rpc/types.h file.
Copy landread.c.dist to landread.c in share directory to bypass compile error."


According to the prompt of the system, I copied landread.c.dist to land.c in share directory and compiled. The compilation process run, and run for about 9 hours, but I don't get the executables.The log compile file have the next message:problems building executables, look for errors in the build log.I search for the word "Error",but I can't see any Error.

These is my new log file and config.
 

Attachments

  • 20220303-2.log.compile
    944.9 KB · Views: 16
  • 20220303-2.configure.wrf
    20.4 KB · Views: 18
Hi,
I still see the same error. One more test - just to help narrow this down a little. Can you try to compile this as a 'basic' nesting option, instead of for vortex-following, just to see if the issue is specific to vortex-following?

Another question - are you compiling this on a local computer/server, or on a cloud machine?
 
Hi,
I may not understand your words well :? , I always choose "basic" as the nesting option when compiling, not "vortex-following".Compiler choice: 34 and Nesting option: 1.
And I compile this through a cloud computer.
Thank you very much for your help!
 

Attachments

  • 20220306.configure.wrf
    20.4 KB · Views: 15
  • 20220306.log.compile
    944.6 KB · Views: 16
Okay, I'm not sure why I thought you compiled with the vortex-following option. Perhaps I was looking at the wrong compile log (from someone else). I apologize for the confusion.

If I remember correctly, I believe this is the same compiling error I was getting when compiling on a cloud machine and the problem ended up being that the instance type I was on wasn't large enough. The error doesn't make a lot of sense if that's the issue, but I was able to overcome it by using a larger instance. Can you test this with a larger instance?
 
Hi Kwerner ,
As you say , I think my instance type is not large enough , so I change to compile through a local computer and it worked.
Thank you so much!!

However , when I run WPS , I came across a new problem. Geogrid runs successfully but when I try to run ungrib I get this error message:

"./ungrib.exe: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory"

However, as far as I can tell that file does exists, in /Build_WRF/LIBRARIES/grib2/lib/libpng12.so.0 .

I issue the following in my /Build_WRF/LIBRARIES/grib2/lib/ directory:

ls -ls >& lib.txt

those are my lib.txt file and configure.wps file.
View attachment lib.txt
View attachment configure.wps
Thanks again for your help!

Fitz
 
Hi,
As this is a new issue, please post it in the ungrib section of this forum. We want to keep topics separated to allow for better searchability for users. Thanks!
 
Top