Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Wrf compile error in vortex flow

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

I have tried to compile wrf for vortex following
but I am not able to get executables.
Here before I have compiled wrf with basic option and it have worked properly.
Do I need to compile WPS also ?
Here I have attached configure (WRF) and log file of compilation.


  • configure.wrf
    20.3 KB · Views: 46
  • log.txt
    734.4 KB · Views: 43
Have you tried to compile Basic WRF recently? Is it possible that anything has changed in your environment (e.g., updated libraries, compilers, paths, etc.)? If it's been a while since you compiled the basic version, will you try that again now to see if you get the same problem?

For vortex-following, yes, you will need to have WPS compiled, as well.
Once you figure out if this same error happens with a basic WRF compile, I would like you to try something. First I want to know which type of Linux you are using. Please issue the following:
cat /etc/os-release >& linux.txt
I'm also attaching a script that I want you to put in your WRF/external/esmf_time_f90 directory and then execute it. Do not attempt to clean the WRF code or anything before issuing it. Just leave it as-is and send the output from that script, along with the linux.txt file you created in the step before. Thanks!


  • wrf_compile_script.csh
    2.4 KB · Views: 46