Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF configure on HPC, Not found

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am trying to configure WRF3.3 on HPC, but it gives an error as follows.

"Error : Not found /apps/netcdf/intel/4.3.2/include/ Please check this installation of NetCDF and re-run this configure script"

But there is in the folder! and I am not sure why the error comes out.
I have loaded the required modules (intel/2020.0.088, hdf5/1.10.3-intel, netcdf/4.3.2-intel, openmpi/4.0.3-intel) and added PATH (NETCDF, HDF5, JASPERLIB, JASPERINC) to HPC environment.
I have chosen 79 (dm+sm) and 1 (basic) among the configure options.

I have attached the complete "configure.log" file generated by running configure.
Any comments would be very appreciated.

* I have also tested using NetCDF-f 4.4.4 -intel module but got the same error message.

Many thanks.


  • configure.log
    8.3 KB · Views: 58
WRF Version 3.3 is a very old version and it's possible that the compilers on your HPC may be too new for the code. I'm not sure that explains the exact error you're seeing, but it's something to consider. Can you try the following?
1) Try to build the latest version of WRF (V4.2.2) to see if that works. That will tell us if the problem is with the old WRF code.
2) Try to build V3.3 code with the dmpar option instead of dm+sm - we often see problems related to this option and we don't typically recommend using it.

If those fail, please attach the compile logs and new configure.wrf files for both of those so that I can take a closer look. Thanks!
Thank you for your response.

WRF Version 3.3 is an old version but I have been extending work that someone did some years back.
I have tried what you suggested, and the results are below.

1) WRF Version 4.2.1 works fine on HPC means that the problem is with the old WRF code (please see wrf4.2.1configure.wrf).
2) WRF Version 3.3 with the dmpar option with the same modules used to build V4.2.1 does not work.

3) The problem may be related to the versions of the compiler (as shown in 1)), so I have tried to build V3.3 with on old version of library (netcdf4.1.3 with intel/ compiler) but got the same error message (please see wrf3.3configure.log and wrf3.3configure.wrf). There is in the folder.


  • wrf4.2.1configure.wrf
    20.8 KB · Views: 60
  • wrf3.3configure.log
    9.1 KB · Views: 46
  • wrf3.3configure.wrf
    20.7 KB · Views: 51
Is your netcdf built as netcdf-c and netcdf-fortran separately? Based on some things I found online, this seems to be a common error when it's built this way. If that's the case, take a look at this page, which describes how to best organize those separate libraries as a single package. See if that helps.