Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe crasch at second run

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


After a first run with 26 gfs hourly files that ends normally, the following run with new gfs files crash with segmentation fault error just after processing the first gfs file. I tried to change some options in namelist.input but it always crash at the same step with the same error.
Could you help me to solve this problem
I download forecast hourly 0.25 degree gfs file with subregion filter.


  • rsl.error.txt
    1.9 KB · Views: 46
  • namelist.input.txt
    3.4 KB · Views: 47
I'm not sure if this is related to the new GFS data, but regardless of this new error, your domains are way too small. We suggest having e_we and e_sn no smaller than 100x100. Take a look at this best practice page that provides advice for setting up a good domain:
Thanks for your answer, i made some progress in resolving the problem.
I noticed that the qr_acr_qg.dat and qr_acr_qs.dat files had an earlier date than the wrf * files. After deleting these files, processing regenerated them and finished normally, without changing any thing in the namelist.input.
I looked for what was the function of these files, apart from being used by the mp_thompson module, I couldn't find any other information.
I would like to know why these files seemed corrupted after the first run and do they need to be systematically regenerated?
Detailed information about these files would be welcome.
As additional information, the freezeH20.dat file must also be regenerated. Looks like I have to delete these 3 files before each run.
Could someone confirm this is normal behavior?
Any information would be welcome
Thanks in advance
I'm glad you were able to resolve the problem. It is actually very odd, though, as I've never had to regenerate those files. As a matter of fact, I keep those files saved in a location and link them into directories where I'm running WRF with the Thompson scheme because those files take so long to create if they aren't already in the directory. I'm able to use the same files for any run and any fairly new version of WRF.
It's not so clear. I encountered the problem again although I had regenerated them. So i migrated to the last version 4.2.1. Since it works fine without regenerate those files. I hope the problem is definitely solved.