Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe crashed suddenly without errors in rsl

wrfyangliu

New member
Hello,

I am simulating few days of weather by WRF Noah-MP. I have successfully executed WPS and real.exe. But when I run wrf.exe, it always crash suddenly without errors in rsl.
I've tried adjusting time_step from dx*6 to dx*3, but the problem still hasn't been solved.
Or is there a problem with the namelist setting?

Anyone could give some advice? Thanks so much in advance!

Yangliu
 

Attachments

  • namelist.input
    4.6 KB · Views: 3
  • rsl.error.0000
    7.8 KB · Views: 5
  • rsl.out.0000
    7.8 KB · Views: 0
  • namelist.wps
    831 bytes · Views: 0
Last edited:
In your namelist.inpout, you specify the sst update file by the settings below:
io_form_auxinput4 = 2,
auxinput4_inname = "wrflowinp_d<domain>"
auxinput4_interval = 360, 360, 360,

But you didn't set the sst_update option. Such inconsistent options may lead to weird behavior of the model. please make them consistent and retry again. Let me know if you still have issues running this case.
 
Dear Ming,

Thanks for your reply! I have deleted the settings of sst update, but the problem remains unresolved.

I tried two-nested domains, wrf.exe works well. Compared with three-nested settings, I haven't changed anything except removing the outermost nesting. File as attached.

Unfortunately, for research purposes, I have to use three-nested domains. With three-nested, I tried running different combination of nodes and ntasks, I tried changing the driving data from ERA5 to FNL,I also tried to shrink the size of d02 and d03 to the minimum needed. But the wrf.exe crashed every time.

What I find interesting is the rsl.error.0000 always end with 6th step, such as:
1:
Timing for main: time 2018-08-21_00:00:06 on domain 3: 3.49978 elapsed seconds
Timing for main: time 2018-08-21_00:00:12 on domain 3: 0.27070 elapsed seconds
Timing for main: time 2018-08-21_00:00:18 on domain 3: 0.27109 elapsed seconds
Timing for main: time 2018-08-21_00:00:24 on domain 3: 0.27109 elapsed seconds
Timing for main: time 2018-08-21_00:00:30 on domain 3: 0.27150 elapsed seconds
Timing for main: time 2018-08-21_00:00:30 on domain 2: 9.26382 elapsed seconds

2:
Timing for main: time 2016-10-06_00:00:04 on domain 3: 2.92672 elapsed seconds
Timing for main: time 2016-10-06_00:00:08 on domain 3: 0.17259 elapsed seconds
Timing for main: time 2016-10-06_00:00:12 on domain 3: 0.17245 elapsed seconds
Timing for main: time 2016-10-06_00:00:16 on domain 3: 0.17269 elapsed seconds
Timing for main: time 2016-10-06_00:00:20 on domain 3: 0.17290 elapsed seconds
Timing for main: time 2016-10-06_00:00:20 on domain 2: 7.59697 elapsed seconds


There might be some clues? Or there is a problem with my domain settings?
 

Attachments

  • three-nested_namelist.wps
    810 bytes · Views: 1
  • three-nested_rsl.error.0000
    8.8 KB · Views: 0
  • three-nested_rsl.out.0000
    8.8 KB · Views: 1
  • two-nested_namelist.input
    4.1 KB · Views: 3
  • two-nested_namelist.wps
    794 bytes · Views: 0
Hi Yangliu,
I compare your namelist.input (for 3-nested domain) and two-nested_namelist.input. The integration period is different between the two cases. But the rsl files seem to indicate that the 3-domain run is over 2016, while the namelist shows it is over 2018. I don't know what data you used to drive this case. Note that some forcing data (e.g., GFS) could be changed and may possibly cause issues.
Also, your nested domain D02 seems to be located at different places based on namelist. This may lead to differences in topography, etc. and possibly affect model simulations.
Another issue is, the error message doesn't necessarily be in rsl.error.0000. It could be in any rsl files. Have you checked all your RSL files?
I believe this case failed due to some errors in physics/dynamics, although I don't know where and how. Please check all your rsl files and let me know if you find something.
 
Hi Ming,
I appreciate for your response. After many checks, I found the problem. The crashed was solved when I changed physics from sf_lake_physics=0,0,1 to sf_lake_physics= 1,1,1.
Thank you again for your help.
Yangliu
 
Top