Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe crashes when setting one more eta-level near surface in high-resolution run

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.



I am using WRF 4.1.3 to downscale hourly ERA5 data with a grid ratio of 1:5 (25 km, 5 km, 1 km, 200 m, 40 m) over an area in the Rocky Mountains, using SRTM1 topography in d03, d04 and d05.

I managed to get wrf.exe to work with:
1) Shifting the domains (such that the boundaries are not over mountainous terrain)
2) Using 1-2-1 smooth option in geogrid.tbl
3) Setting w_damping = 1 and damp_opt = 3 (needed for my usecase)
4) Running on 7 nodes with 20 processors each
5) Setting epssm to 0.1, 0.1, 0.1, 0.7, 1.0
6) Setting e_vert to 90 (while keeping the model top at 5000)
7) Setting the time step to 45 s

I would like to increase the number of vertical levels near the surface. At the moment, I have levels at 0 m, 48.21 m, 109.11 m, … I would like to have one more level, e.g., at 25 m.

I set the eta-levels manually, but I can’t get the model to work. I used the same specifications as above, except:
- Setting epssm very high to 0.1, 0.5, 0.5, 1.5, 2.0
- Reducing the time step to 40 s (a shorter time step will require too much time for me to run the experiments)
- Setting e-vert to 91 and setting the eta-values manually, while using the same eta-levels from above, and including only one level (at 0.997)

The error is:
[n040:19446] *** Process received signal ***
[n040:19446] Signal: Segmentation fault (11)
[n040:19446] Signal code: Address not mapped (1)
[n040:19446] Failing at address: 0xfffffff605ec2448

I tried many different test runs, e.g.:
- Same as TEST 1, but specifying the eta-levels manually to the same ones as TEST 1 --> worked
- Increasing the number of vertical levels to e_vert = 200 --> gives almost the exact same vertical levels near the surface
- Setting the p_top_requested to 10000 --> gives again almost the same vertical levels near the surface

Can you please help me to get one more vertical level near the surface (e.g. at 25 m)? Am I missing anything?



  • namelist.input
    6.8 KB · Views: 43
  • rsl.error.txt
    9.2 KB · Views: 30
If you didn't already do this, I would recommend first following the procedures mentioned here. After you run real.exe without specifying your eta_levels, yourself, you can use the command:
ncdump -v ZNW wrfinput_d01
to see the model-suggested values for eta-levels. From there, you can play around with the values to see what works. Unfortunately, there is no specific formula for determining the right values. It's just a matter of playing around with it a bit. If you're still having problems, I would recommend trying some debugging to determine exactly where in the code the problem is occurring and see if you're able to correct it with that information.
Thank you very much for the reply! I appreciate it a lot.

Yes, I have already inserted the model-suggested values for eta-levels and tried to modify them, but couldn't make it work so far. I will further try different options for the eta-levels in combination with epssm and reducing the time step, and use debugging.