Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe error for running in 1/3km

Hilson Liu

New member
Hi all,

I'm trying to run a four-domain simulation(9km/3km/1km/ with WRF-UCM. However, no matter how I change the time_step(54/30/18/9) and the number of cores(6/8/12/16), the simulation always terminates in the first 24 minutes of the simulation time with the same segment error.
I have attached the namelist file and error file for understanding my settings.
A) For 9km, 3km, and 1km domains, I used the same e_sn and e_we in another four-domain simulation(27km/9km/3km/1km). It worked very well.
B) In 'rsl.error.0003', there is an notice before simulation stop, 'rrtm: TBOUND exceeds table limit: reset 624.390'. But my study area doesn't include tropical area.
Looking forward to some ideas about this situation.....


  • namelist.input
    5.3 KB · Views: 3
  • namelist.wps
    1 KB · Views: 1
  • rsl.error.0000
    707.3 KB · Views: 2
I'd first like to apologize for the long delay in response. Thank you for your patience.
It's difficult to say exactly why the model is stopping with the provided information. I can't explain why your other simulation worked properly, but there are some domain settings that don't follow the recommended protocol.

1) The size of your domains is a bit small.
e_we   = 52,  73, 136, 289,
 e_sn   = 76, 109, 202, 427,
Each domain should be no smaller than 100x100 grid points.

2) Your domain boundaries are also probably too close together - especially domains 03 and 04. Since the model is stopping when processing d03, this could be the issue.

Take a look at these best practices to set up your domain properly. If you make your coarser-resolution domains much larger, you can also use more processors to run this. And you wouldn't be spending that much more, computationally, because the majority of computation is happening on the finer-resolution domains. See Choosing an Appropriate Number of Processors.

If you make these modifications and the model still stops, first check your input files to make sure there are no NaNs or anything that looks odd with the variables. If you don't find anything, please package all of your rsl.* files together into a single *.tar file and attach that, along with the modified namelist.input and namelist.wps files. Thanks.