Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.



I am running the WRF model with four nested domains using ERA5 data. The wrf.exe stops and I am not able to understand the error. The same error occurs with max_dom=3. Please, find attached the namelist.input and error files. The initial and boundary conditions from real.exe can be download at:

Best regards,


  • rsl.out.0000.txt
    4.5 KB · Views: 48
  • rsl.error.0000.txt
    5.2 KB · Views: 50
  • namelist.input
    6.6 KB · Views: 45
Using your namelist and input files, I am able to run your case without any problems, so this seems likely to be a problem on your system. Could you be out of disk space in the area you are writing files, or not have permission to write the files there? Take a look at some of your other rsl.error.* files to see if they may have any errors in them. If you do a full listing:
ls -ls rsl.error*
then you can check the size of the output file. If any is particularly larger than the others, it may hold some additional information in it.

Thanks for your reply. I tried again to run the wrf with the same input data. Please find attached my namelist.input and new rsl files with the largest size. Can you check if there is additional information? Are you able to see what is the problem this time? I changed the output path, there should be no issues with permission to write the files there, because a single wrfout file has been generated.

[gevorgyan1@juwels09 run]$ ls -l /p/scratch/prpb81/
total 1024640
-rw-r--r-- 1 gevorgyan1 prpb81 1049215120 Feb 5 00:53 wrfout_d01_2018-08-02_12:00:00

Best regards,


  • namelist.input
    6.7 KB · Views: 45
  • rsl.out.0133.txt
    3.9 KB · Views: 49
  • rsl.error.0065.txt
    5.9 KB · Views: 45
Can you please mention how many CPUs did you use? Is it possible that I am using not enough CPUs (200 in my case)? Did you wait for some time after starting the simulations? It is possible that the run fails after short time of beginning of simulations.
I used 216 processors, which had a decomposition of 12x18. I only ran for 24 hours, but that is 24 hours longer than your run was able to simulate, as yours stops immediately.