Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe problem

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I have installed WRF-4.1.5 /WPS-4.1. (I used icc/ifort). When I run the model, the pre-processing programs i.e. geogrid, ungrib, metgrid are performed successfully. Also the real.exe ran successfully but the error occurred on when I run the wrf.exe.
Specifically I get the following:

wrf@workstation:~/WRF/WRF-4.1.5/run$ mpirun -n 4 ./wrf.exe
starting wrf task 1 of 4
starting wrf task 3 of 4
starting wrf task 0 of 4
starting wrf task 2 of 4

= PID 18285 RUNNING AT workstation
= EXIT CODE: 139
This typically refers to a problem with your application.
Please see the FAQ page for debugging suggestions

Could anyone please help me? What does this mean? How to overcome this error? I found similar error cases but not exactly
that problem that I have, as you can see into the Attachements.
Thank you !!!


  • namelist.input.txt
    4 KB · Views: 48
  • rsl.error.rar
    3.2 KB · Views: 39
  • rsl.out.rar
    2.9 KB · Views: 47
Can you send the rsl files in a packaged *.tar file (instead of .rar - unfortunately we are unable to open a .rar file). Thanks!
Yes, of course! Here are the rsl files in a packaged *.tar . Thanks a lot!!!


  • rsl.error.tar
    20 KB · Views: 42
  • rsl.out.tar
    10 KB · Views: 40
Thanks for sending those. Unfortunately there wasn't any useful information in them; however, I took a closer look at your namelist and I see that you have your time_step set to 450. Your time_step should never be any larger than 6xDX. I would start with reducing that. I also see that your domains are very small (76x76). Unless you're just playing around with the model to learn how to use it, we recommend domains that are at least 100x100. Take a look at this page that provides several best practices for your domain set-up. If interested, there is also one for the WRF namelist variables, as well.
Thank you very much for your advices!!!
I am new to wrf and I try to learn it, but into the namelist.input file I set the time_step = 60 and dx=10km.
I only use max_dom =1 and I set e_we = 100, e_sn = 100.
I try to understand what went wrong because as you said, in my rsl files there wasn't any useful information indeed... :( :(
Typically if the run is stopping immediately, the problem is related to the input data. You should take a look at your met_em* files and make sure there is no data missing, or bad data. Make sure everything looks reasonable at all levels. If that doesn't seem to be the problem, can you send me a few files so that I can take a look?
1) your latest namelist.input file
2) your latest rsl.* files
3) a couple time intervals of your met_em.d01* files. If these files are too large to attach, take a look at the home page of this forum for information on sending large files (unless you have another method - e.g., a link)
The run stops after the first output ( wrfout_d01_2021-03-22_00:00:00 ) created.As for my met_em* files, I can't detect any problem. So, here I have :
1) My latest namelist.input file
2) My latest rsl.* files
3) And a couple time intervals of my met_em.d01* files.
If there is a problem in opening the files in that format, please let me know.
Thank you again!!!


  • namelist.input
    3.7 KB · Views: 46
    3.8 KB · Views: 43
    710 bytes · Views: 41
    3.5 KB · Views: 44
The met_em files you sent aren't the actual files. They are just links to the files. Can you try again to send me the actual files? Thanks!
You were right, I am sorry... My mistake!!!
I hope it will be ok now. Thank you again!!!


    13.8 MB · Views: 38
Thank you so much for sending those. I was able to run a test simulation using WRFV4.1.5, your namelist, and your met_em* files (using 4 processors) and everything ran fine. This would indicate that your problem is system-related. I would start by checking your disk space to make sure you have enough space to write the files. I assume you have not made any modifications to the WRF code and it's built as "out-of-the-box?" If you've made modifications to the code, test out a pristine version of 4.1.5 to see if that makes a difference. If so, then you know it's related to your mods. If neither of those are the issue, unfortunately you will need to discuss the problem with a systems administrator at your institution to see if they know why your system is doing this.