Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF Installation Error: One of compilers testing failed! Please check your compiler

shahbaz757

New member
Hi,

I am building the WRF model on my vmbox ubuntu, I am following this tutorial -https://www2.mmm.ucar.edu/wrf/OnLineTutorial/compilation_tutorial.php
I installed all the required libraries and passed all the tests but while I configure the WRF it is showing me "One of compilers testing failed! Please check your compiler" Error-

1670944051478.png

Here are my test-passed screenshot -
1670944087340.png
1670944097741.png

I have also set the environment variables as mentioned in the tutorials -

1670944214549.png
1670944158476.png

I have deleted and reinstalled everything, but the same message appears.
Can you please help me with this, what might be the issue here?
 
Hi,
Did you try to compile after that configuration to see if it compiles anyway? Try that, and if it doesn't, please attach your configure.wrf file, as well as the full compile log. Thanks!
 
Hi, Thanks for the quick reply.
I tried to compile but I guess it didn't work out.
I am attaching the configure.wrf and log file. Please look into it
 

Attachments

  • log_file.zip
    14.4 KB · Views: 3
I notice that in the log file it says "pgf90: Command not found"
Even though I followed the procedure as mentioned in the tutorial and passed all tests, it is throwing this error.
In the tutorial, I can only see that gfortran is required, with no mention of pgf90.
are gfortran and pgf90 different compliers? and do I need to install pgf90 separately? If yes can you guide me to any tutorial for that?
 
Hi,
pgf90 indicates you've chosen to use the PGI processor for compiling. That is different than gfortran. You need gfortran, regardless, because the code is written in fortran, but you can choose to simply compile the code with a gfortran/GNU option, or if you want to use PGI, you'll need to have it installed. It's not a free compiler, so it's unlikely you would want to purchase it, if you (or your institution) don't already have it. If you want to try to compile with GNU, issue a 'clean -a' and then reconfigure and choose the gfortran/dmpar option (probably option 34).
 
Hi, Yes that makes sense I reconfigured the WRF and I think the compilation is completed but at the end, log file says "--> Problems building executables, look for errors in the build log <--"
I checked WRF/test/em_real and see the executables is created but it is not created in WRF/main, I am attaching the new log file can you please check and tell me what might be the issue here?
Thank you so much for your help.
 

Attachments

  • wrf_log.zip
    56.1 KB · Views: 1
The error message that is printing is:
Code:
wrf_io.f:1498:36:

 1498 |   CALL ext_ncd_open_for_read_begin( DatasetName, Comm1, Comm2, SysDepInfo, DataHandle, Status )
      |                                    1
Error: Dummy argument ‘datasetname’ with INTENT(IN) in variable definition context (actual argument to INTENT = OUT/INOUT) at (1)
wrf_io.f:7454:58:

 3162 |       stat = NF_PUT_ATT_INT (DH%NCID,NF_GLOBAL,Element,NF_INT,Count,Data)
      |                                                                    2
......
 7454 |     stat = NF_PUT_ATT_INT(NCID,VarID,'FieldType',NF_INT,1,FieldType)
      |                                                          1
Error: Rank mismatch between actual argument at (1) and actual argument at (2) (rank-1 and scalar)
wrf_io.f:7516:71:

which is a known issue, at least with the GNU/V10 compiler, and likely with V11 as well. The WRF code was modified to address this issue. Can you try the latest version of WRF (V4.4.1) to see if you're able to get past this issue?
 
Hi, I tried with the latest version - WRF (V4.4.1) however, I am still getting problems building executables.
Here is the new wrf log file, please have a look.
Thank you so much for your help.
 

Attachments

  • wrf_log.zip
    55.7 KB · Views: 2
Hi,
When you compiled netcdf, mpi, and all the other libraries, did you use the same GNU compiler to build those, as you're using to build WRF? If not, you must make sure to build those with the same compiler. It may be worth trying to run the tests from the compile tutorial again. Unfortunately, when building on a virtual box, there are often paths/links that are "hidden" in the background, from your other environment, and those can cause problems for the paths you're trying to set in the virtual environment. It may be worth asking for assistance from a systems administrator at your institution.
 
Top