Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf-python on cheyenne

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I'm trying to install wrf-python on cheyenne. I have cloned the ncar_pylib into my glade/work space and did 'pip install wrf-python'. This generated a Module Not Found Error: No module named 'chey_intel'. I thus tried to 'pip install chey_intel' but I get the message 'Could not find a version that satisfies the requirement chey_intel (from versions: ) . . . No matching distribution found for chey_intel.

I ran into the same error when I used a non-cloned environment. Any suggestions would be helpful. Thanks!

Unfortunately our group does not develop or support the WRF-Python package. You can find information about contacting their support group from this page:
I'm actually facing the same problem. Did you finally figure out a way to fix the problem? Would really appreciate the help.
It does seem to work now by first loading the Python2.7 module, then doing the ncar_pylib command, then cloning/activating that environment into my /glade/work/ space. I'm not an expert at this, but I think it may be an issue with Python 3 vs. Python 2.7. Hope that helps!