Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF SIGSEV & CFL Errors when using certain values of SPPT

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Good Afternoon WRF Help,

I'm wondering if someone could shed some light on a problem I have been encountering with the WRF model. As part of an experiment I'm running, I need to use various values of settings for the Stochastic Physics Perturbation Tendency (SPPT) scheme. I have managed to get one five day run completed using a value of 0.5 for sigma and 2.0 for the sigma cutoff, but when I try to increase sigma to 1.0 for the second run, I cannot seem to get past a number of errors (This is the only thing that changes between the two runs, everything else is exactly the same).

At first, these manifested in really high values of CFL that were being exceeded, in the past I had rectified these issues by increasing the EPSSM value, and I tried to perform this, increasing the EPSSM of the run from 0.1, to 0.2, to 0.25, to 0.5 (Which worked at first), but caused a different SEGFAULT (Below). I even shifted the run time by one day to see if perhaps the input data were the source of the problem, but I had CFL errors again at 0.5, and increasing to 0.75 did not seem to help.

In all cases though, the run aborts shortly after an hour in (The first set always aborted one hour and 30 minutes in regardless of the EPSSM setting), while the new run aborts shortly after one hour in. The error I'm encountering is (I upped the debug_level to 1000 to try to capture the call trace):

d01 2012-04-10_01:04:00  DEBUG wrf_timetoa():  returning with str = [2012-04-10_01:04:00]
d01 2012-04-10_01:04:00  call radiation_driver
d01 2012-04-10_01:04:00 Top of Radiation Driver
d01 2012-04-10_01:04:00 calling inc/
d01 2012-04-10_01:04:00  call surface_driver
d01 2012-04-10_01:04:00 in SFCLAY

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  0x7F970BE6A6D7
#1  0x7F970BE6AD1E
#2  0x7F970B1493FF
#3  0x2C69DAD in __module_sf_sfclayrev_MOD_psim_stable
#4  0x2C6E3FC in __module_sf_sfclayrev_MOD_sfclayrev1d
#5  0x2C732DD in __module_sf_sfclayrev_MOD_sfclayrev
#6  0x22C5090 in __module_surface_driver_MOD_surface_driver
#7  0x1A4CC87 in __module_first_rk_step_part1_MOD_first_rk_step_part1
#8  0x13C9906 in solve_em_
#9  0x1256260 in solve_interface_
#10  0x47EF3B in __module_integrate_MOD_integrate

The most current namelist I am using, along with the rsl out/error files associated with the rank that failed have been attached to this topic. Any pointers to what seems to be going on here would be appreciated.



  • namelist.input
    6.4 KB · Views: 19
  • rsl.error.txt
    5.1 MB · Views: 16
  • rsl.out.txt
    5.1 MB · Views: 15
I just want to let you know we aren't ignoring you. I'm trying to get in touch with our SPPT developer to see if they are able to offer any advice. I'll let you know when I hear from them. Thank you for your patience.