Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF stops after restart with no errors


New member

I am running WRF version 4.5 for a 10-year simulation in chunks of several months. It consists of one domain at 9 km resolution. After the restart, the rsl.out.0000 gets stuck in SOIL TEXTURE CLASSIFICATION = STAS FOUND 19 CATEGORIES and does not write any wrfout, but the simulation goes on running till walltime is reached. I checked for errors in the rsl files and I found nothing.

Has somebody faced the same problem? Does somebody know how to fix it?

Many thanks


  • namelist.input
    5.3 KB · Views: 3
  • rsl.out.0000
    2.3 KB · Views: 3
When did the 10-year simulation start? i.e., have you already been able to successfully restart the model prior to this instance where it has stopped? Have you checked your wrfrst* file to make sure nothing is missing and everything looks reasonable? Can you package all of your rsl* files together in a single *.TAR file and attach that? Thanks!

First of all, thank you very much for your message and sorry for the late reply.
I started the simulation on 01-12-2007 and I could restart the model without any problem several times till now using mpirun -np 128. I have tried to restart from an earlier period and it did not work either. I have tried now to start from the beginning (01-12-2007), when there was no problem in the boundary conditions files, and still, it is not able to run when I use mpirun -np 60 or any other number that is not 1. Any idea how I could overcome this issue?

Please, find in NextCloud under the name rsl_files.tar.gz all my rsl* files for the simulation I tried now for the first day. I also attached the namelist.

Many thanks!


  • namelist.input
    5.4 KB · Views: 1
Thanks for sending those files. If you were able to run this previously and had no trouble, and now you are simply starting from the beginning again (running exactly the same thing you successfully did before), and it's not running, then this is likely an issue with your system/environment. Is it possible that you've run out of disk space? I would suggest discussing the issue with a systems administrator at your institution to see if they have any thoughts about what may be happening.