Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF stops at reading wrfrst

sveinngauti

New member
I am trying to run a restart run. I have all the neccesary files but whenever I try to do a restart run the last line written in the rsl.out files is

d01 2014-10-01_21:00:00 Input data is acceptable to use: wrfrst_d02_2014-10-01_21:00:00

WRF keeps on running, or at least using up 100% of my processes but nothin seems to happen. Nothing is written in wrfout files and nothing in rsl.out files either. When I do a non-restart run everything works smoothly. I also tried to run it with a single core (-np 1) and then I can do the restart run. I've attached my namelist.input and my rsl.error.0000 file.

I'm using GNU compilers, Ubuntu 22.04, Intel i9 and WRF 4.5.1.

Does anyone have any idea what might cause this issue?
 

Attachments

  • namelist.input
    3.3 KB · Views: 2
  • rsl.error.0000
    2.8 KB · Views: 2
Last edited:
Hi,
Can you let me know how many processors you are using to run this? For some reason that information is missing from the top of your rsl* file. Will you also please package all rsl* files together into a single *.tar file and attach that?

When I do a non-restart run everything works smoothly.
Do you mean that when you do the initial run, it's okay, and then when you run the restart, this happens? Or are you able to run a single (non-restart) simulation all the way through this time period (when it's failing) without issues?
 
Thank you for your reply. I'v tried running with 2,4 and 8 processors but none work. The only way I've managed to run a restart run is on a single processor.

I am able to run non-restart runs for the whole time period with both 4 and 8 processors without problem. I've attached all of the rsl files. They all seem to show the same thing though.
 

Attachments

  • rsl.out.zip
    10 KB · Views: 2
Thanks for sending those. Since you're able to run non-restart simulations for the entire time period, is there a particular reason why you need to run a restart in the middle of that simulation?

One thing to note, and I don't think this is causing the issue, but d01 is too small. Your domains should always be at least 100x100 grid spaces. If you absolutely need to use the restart feature, try to increase d01 and run again. Assuming it will still fail, let me know, and please share all the files I will need to try to repeat your case (e.g., wrfbdy_d01, wrfrst* files for the restart time). The files will likely be too large to attach here, so take a look at the home page of this forum for instructions on sharing large files. Thanks!
 
Top