Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF v4.0 compilation errors on TACC

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I have been having troubles compiling WRF (v4.0) on the TACC (Texas Advanced Computing Center) system.

After several attempts I was able to identify (most) of the libraries and have made quite a lot of progress. However, I am still having trouble compiling the code.

I am attaching here my configuration file and the log file of the compilation.

Please, let me know if you have an idea of where the problem is coming from.

Best regards,



  • compile_em_real.07.log
    701.7 KB · Views: 57
  • configure.wrf
    22.2 KB · Views: 47
Hi Svetla,

It looks like the problem may be occurring because it's not able to find the MPI library. Based on some of the paths in your compile log, it looks like you may have already been following the online compiling tutorial:

If so, did you follow it word-for-word, exactly as is indicated? This strategy helps to eliminate unnecessary errors. Even if you previously had some of the libraries installed, install them again in the directories given in the tutorial. Make sure that you put these libraries in your PATH, and it helps to put them in your environment script (e.g., .cshrc, .bash, etc.).

If you think that you did everything right, can you issue:
echo $PATH >& path.txt

and attach that path.txt file?

Dear Kelly,

Thank you for the reply!

I did install the libraries, according to the tutorial but then I loaded specific TACC modules that have their latest libraries. I am not sure if I should stick with the WRF libraries (from the tutorial) or use the TACC libraries. What is your suggestion???

Please, see attached my .bashrc file, as well as three txt files that give my environment - path.txt, LD_LIBRARY_PATH.txt and CPATH.txt

Please, advise me on:
- what to specify in these paths - the WRF specific libraries or the general ones available on TACC
- can I include all of them? is the order important?

I think I originally tried using just the WRF-specific libraries but I had even more problems with the MPI. This is why I am now including the TACC libraries.

One possible problem with my first approach is that I installed the WRF libraries before loading the TACC modules. Maybe I should recompile the WRF libraries with the TACC modules first loaded ??? By the way, I made all the test then and they all worked. Have not checked now if they are still working. Maybe they do not work anymore.

Here is my structure of directories:
working directory: /home1/06077/hristova/WRF
subdirectories :Build_WRF and TESTS
subdirectories of Build_WRF: LIBRARIES and WRF

Thank you very much for your support!!!

Any advice will be greatly appreciated!!!

Best regards,



  • bashrc.txt
    4.6 KB · Views: 54
  • path.txt
    462 bytes · Views: 48
    979 bytes · Views: 52
  • CPATH.txt
    374 bytes · Views: 50
Hi Svetla,

To keep things simple, so that we can attempt to track down the problem, I advise that you only use the libraries from the WRF compilation tutorial. It's much harder to diagnose the problem when there are several variables to consider. If you are also loading other modules, then you are overriding the installations from the tutorial web page, and this may be causing problems with mis-matched libraries (e.g., you may have a library that is compiled with a different compiler than the one you used to build another library, or WRF). Please first try to follow the online tutorial word-for-word (starting over from scratch in a clean directory), and if you aren't able to build WRF, then please send your configure.wrf and compile log at that time. If you can get past this initial problem, and at that point you'd like to use the TACC libraries instead, you can attempt again with those modules loaded.

To answer your question about 'order,' yes order does matter in your $PATH. Whatever is set last will overwrite the previous setting.