Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF 'vortex following' option

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi everyone,

I'm new to this forum, so apologies if there is a special format I'm not following.

Regarding the WRF 'vortex following' option (note: all the tests below are with GitHub repository WRF):
- The switch doesn't compile in WRFv4.3 (option 15/3):
- I've tried WRFv4.1, it compiles OK, but hangs/aborts without an error at initialization with triple-nest TC run (for MP options #8 and #30).
The nests are not that large d01-501, d02-601, d03-802 x 55 levels.
- I've tried WRFv4.2 / WRFv4.2.1 / WRFv4.2.2, it compiles OK. However, changing a single line by adding a single variable (for example in 'registry.sbm') crashes the compilation with very weird errors.

The attached file is a compressed WRFv4.2.2 github directory.
The 'master' branch compiles OK (option 15/3 with various Intel 2019-2021 and/or with mpich-3.3.2).
The new branch (bold), with a single commit from a single 'registry.sbm' change, doesn't compile.
The broken compilation log file is attached as well. ('WRFv4.2.2_log_cmp_153_d.out').
* Test/add_var_registry
>> git show f9d31110d51632d8dc0b8a1da86d2995f51413c3

Any suggestions?
Does anyone here uses WRF compiled with the 'vortex following' option for TC research? If the answer is YES, what is the most recent WRF version you work with? What are typical domains size and which MP option?

View attachment WRFv4.2.2_log_cmp_153_d.gz
View attachment WRF-release-v4.2.2_GitHub.tgz
Hi Jacob,
I'll check with the developers who were working on that problem and see if I can get any updates, or push for progress on the issue. Is there anything in particular with V4.3 that you need to use, or are you able to use V4.2 in the meantime for your simulations?
Hi Kelly,

Since posting this, I've managed to compile/run WRFv4.2 with option (15/3) with the Intel-2018u3 compiler.

kwerner said:
In case you're interested, an update has been posted to the issue on the GitHub page.

Hi Kelly,

The issue with the 'vortex-following' compilation bug is solved for v4.3.1:

However, another issue indicated in this bug thread is not yet addressed: that is, the 'vortex following' model compilation fails upon a single 'registry.sbm' change (please see the original thread above). This seems like a behavior already seen in WRFv4.2 / WRFv4.2.1 / WRFv4.2.2, where the original code compiles OK. However, changing a single line by adding a single variable (for example in 'registry.sbm') crashes the compilation with very weird errors.
Could you ask around if the maintainers are aware of this bug/behavior?

Thanks a lot,
Hi Jacob,
When adding a line to the registry file, do you also modify the code pertaining to that variable to ensure that it's included, or are you just adding it to the registry.sbm file?
Hi Kelly,

I'm just added a new ('dummy') field to the mentioned Registry file/s, without changing any other parts of the source codes.
It compiles with the standard Intel 15/1 option, but fails with 15/3 - so the usage method seems to be correct.
I've tested all the versions backwards to v4.1.5 (excluded), and all of them fails with the same error.; v4.1.5 compiles successfully.

I've open an issue on GitHub:
It really takes only a few minutes to verify this bug per version (I've tried a shorter/non-optimized compilation with './compile -D').

Thanks, and I also verified what you're seeing. Thanks for opening the issue on GitHub. We will continue to look into it.