Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF4.3/wrf.exe failed with unknown token type

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Feng Liu

New member
Hello all,
I got a error message associated with VEGPARM.TBL during running WRF4.3/wrf.exe. I can run WRF4.2.x with the same input data (produced by WPS) successfully. However, when I run WRF4.3/wrf.exe below message keep appear.
FIO-F-225/list-directed read/unit=19/lexical error-- unknown token type.
File name = 'VEGPARM.TBL', formatted, sequential access record = 190
In source file module_sf_noahdrv.f90, at line number 1981
I package all of my rsl* files and namelist into a single Log.tar.gz file and attach that so that you may take a look.

ThanksView attachment Log.tar.gz
Hi, Maricopa
I suppose you run the case with NLCD landuse type. Please let me know if I am wrong.
Please replace the original VEGPARM.TBL by the one I attach here and hope the model can successfully read this file.
Some codes related to surface schemes have been modified in WRFV4.3 when the LCZ option is introduced. However, their impacts on the model system might not be fully examined. Please et me know whether the attached VEGPARM.TBL works or not. if you have other problems, please also keep me updated. Thanks.


    22.5 KB · Views: 49
Hi Ming,
Thank you so much for your quick response. Wow, you provide me with such a quick solution to my problem. IT WORKS NOW!
Many thanks for the powerful support and quick help.
BTW, yes I am running the case with NLCD landuse type.