Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

aer_opt=3 error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

figurski

New member
Dear all,
I am trying to run WRF 4.0 with the aerosol-aware Thompson Scheme (mp_physics = 28). I attach the data file QNWFA_QNIFA_SIGMA_MONTHLY.dat to the WPS file (namelist.wps).
I set this up in namelist.input:
& domain
wif_input_opt = 1
num_wif_levels = 30

&physics
mp_physics = 28, 28, 28,
aer_opt = 3,
use_aero_icbc = .true.
The real.exe program runs ok, but an error has appeared after running the wrf.exe program.
I attach my namelist.wps and namelist.input files. In addition, I've attached the rsl.error.0000 file for debug_level = 5000.
I used this scheme in version WRF 3.9.1 and everything worked ok.
Can anyone help me solve my problem?
Mariusz
 

Attachments

  • namelist.input
    4.2 KB · Views: 89
  • namelist.wps
    1.2 KB · Views: 65
  • rsl_error_0000.txt
    649.9 KB · Views: 59
Please change the options below from
start_year = 1*2018,
start_month = 1*10,
start_day = 1*21,
start_hour = 1*18,
start_minute = 00, 00, 00, 00, 00, 00,
start_second = 00, 00, 00, 00, 00, 00,
end_year = 1*2018,
end_month = 1*10,
end_day = 1*22,
end_hour = 1*00,

to
start_year = 2018,
start_month = 10,
start_day = 21,
start_hour = 18,
start_minute = 00, 00, 00, 00, 00, 00,
start_second = 00, 00, 00, 00, 00, 00,
end_year = 2018,
end_month = 10,
end_day = 22,
end_hour = 00,

Also please set debug_level =0, then rerun this case.
 
Thank you for the reply.

The above section that you have shown above is not from my namelist.input file. In my namelist.inpu file is:

start_year = 2019, 2019,
start_month = 06, 06,
start_day = 05, 05,
start_hour = 12, 12,
start_minute = 00, 00,
start_second = 00, 00,

So I do not have to change anything here.
I only changed dbug_level from 5000 to 0. However, when running wrf.exe it continues to end with an error (singnal 11 segmentation fault).
I do not know how to solve this problem. I did not have this problem with WRF version 3.9.
 
Hi,
Can you attach all of your rsl* files here (you can package them together into 1 *.tar file)? Make sure to attach the new files, after having changed debug_level to 0. Just an FYI - the reason we suggest changing that to 0 is that this is an old lingering option that was in the namelist for some very specific testing purposes. We recently removed the option, as it rarely gives any useful information, and ends up making the rsl file huge and difficult to read through.

When you ran this option with V3.9.1, was it this exact same run (same domain, dates, namelist options, etc.)?
 
Hi,
I did additional tests for the same data (same domain, namelist.input option etc.). I solved the problem partially. If the WRF 4.0 model is compiled with the dmpar model, it works correctly. The problem only occurs if the WRF is compiled with the smpar + dmpar model. I had a new version of WRF 4.0 and compiled smpar + dmpar, after changing to dmpar, everything was working correctly.
Unfortunately I did not do the dmpar + smpar test for the WRF 3.9 version, the WRF 3.9 dmpar version works correctly.
Mariusz
 
I'm glad to hear that you were able to figure out a work-around for the problem. Are you okay using a dmpar-compiled version of the code? We typically recommend that (or smpar) anyway. We don't do any testing with dm+sm and have seen a lot of problems, both with compiling and running. Unless it's absolutely necessary, we try to recommend staying away from it.
 
Top