Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ERROR while reading namelist physics

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

when I run ./real.exe and ./wrf.exe, there is an error below. and there is
also the physics section below. Could you please tell me how to fix it.
Thank you so much and I'm waiting for your reply.

error message in rsl.error.0000
taskid: 0 hostname: c09n08
module_io_quilt_old.F 2931 T
------ ERROR while reading namelist physics ------
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 10601
ERRORS while reading one or more namelists from namelist.input.
-------------------------------------------
application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0

physics section in namelist.input
&physics
physics_suite = 'TROPICAL'
radt = 30, 30, 30,
bldt = 0, 0, 0,
cudt = 5, 5, 5,
icloud = 1, 1, 1,
num_soil_layers = 4,
num_land_cat = 21,
sf_urban_physics = 0, 0, 0,
sst_update = 1,
/
 
Thank you,
I set icloud = 1 then try again, the error is still same, and I found that when run ./real.exe, it shows below
starting wrf task 0 of 1
could you help me agagin, and thank you.
 
please tell me which WRF version you are using and upload your namelist.input.
Did real.exe run successfully? The error message is from running wrf.exe, I guess? Please let me know if I am wrong.
 
Thank you for your reply, and I use v3.9.1. Then I simplify the namelist.input, I get the wrfout file. As a new beginner, I think there maye be some mistakes at the some step. So I restart the whole step with renew domain again...... Now when I use ncview to check the wrfout file, I find it strange that ncview graphic of wrfout.d01 file doesn't have 4dVar and "time" is ony first initial one in BOTH ORIGINAL ONE AND RENEW ONE. but when I use tutorial case, I get 4DVAR in wrfout file. I don't know why, could you please help me. Thank you and wait for your reply.
ps1: ncview graphic of wrfout.d01 file has 19 "time" variables. comfused, why?
ps2: in this case,I use SST-update,but when I check if SST is updated in the model, field TSK over water is not changing, is it normal?How can I fix it?
 

Attachments

  • 360截图20191212171850173.jpg
    360截图20191212171850173.jpg
    71.8 KB · Views: 4,392
  • 360截图20191212172003843.jpg
    360截图20191212172003843.jpg
    71 KB · Views: 4,389
  • 360截图20191212204614826.jpg
    360截图20191212204614826.jpg
    69.4 KB · Views: 4,393
  • 360截图20191212204625731.jpg
    360截图20191212204625731.jpg
    56.1 KB · Views: 4,396
To answer your questions,
(1) If you set frames_per_outfile = 1000, 1000, 1000,
Then you will have the dimension 'time' in your wrfout files.
If you set frames_per_outfile = 1, 1, 1,
then you only have one single time output in each wrfout file.
frames_per_outfile indicates the number of output times per history output file

(2) sst usually changes little during a short integration period, for example less than 3 days. sst_update is used for long-term climate simulation. You may compare sst in met_em file with sst in wrfout at corresponding times. This is a way to confirm whether sst_update works for your case.
 
Thank you for your reply. For my question, in my namelist.input, I set frames_per_outfile = 1000, 1000, But I don't have the dimension 'time' in my wrfout files. And I find that when when I use fdda secton, it will not show the dimension 'time' in my wrfout files, and there is no wrffdda02 for d02
. But if I remove fdda section, the dimension 'time' in my wrfout files will be normal. Could you please tell me how to do that? Thank you.
ps:for the fdda section, I follow the tutorial page to set, but I don't have the dimension 'time' in my wrfout files, and there is no wrffdda02 for d02.
the second time is
&fdda
grid_fdda = 1, 1,
gfdda_inname = "wrffdda_d<domain>",
gfdda_end_h = 24, 24,
gfdda_interval_m = 360, 360,
fgdt = 0, 0,
if_no_pbl_nudging_uv = 0, 0,
if_no_pbl_nudging_t = 1, 1,
if_no_pbl_nudging_q = 1, 1,
if_zfac_uv = 1, 1,
k_zfac_uv = 10, 10,
if_zfac_t = 0, 0,
k_zfac_t = 10, 10,
if_zfac_q = 0, 0,
k_zfac_q = 10, 10,
guv = 0.0003, 0.0003,
gt = 0.0003, 0.0003,
gq = 0.0003, 0.0003,
if_ramping = 1,
dtramp_min = 60.0,
io_form_gfdda = 2,
/
 
I guess the the case with fdda failed, since you don't provide the wrffdda inout data. As a result, you only have wrfout at the initial time, then the model crashed.
 
Thank you for your reply. I fix the problem and run the whole process. I simulate for several days, and I can get the wrfout file without error, but I find that the wrfout file does not have enough complete time variable and it stops at the third day.
I want run 3, 5 and 10 days respectively, but it stops at the 3rd day both. Could you please tell me how to fix that? Thank you so much.
I don't know how to do with the information in rsl.error.0007.
 

Attachments

  • 360截图20191219125852027.jpg
    360截图20191219125852027.jpg
    195.3 KB · Views: 4,366
Please upload your rsl file and namelist.input for me to take a look. Other information like RWF version and forcing data are also helpful.
 
Thank you for your reply.
And now I have a new problem about namelist.input and wrf.exe.
When I simulate a hurricane case, I set the e_vert=36, I can get the wrfout file with complete times dimension,
But when I only change e_vert=66, and add eta_levels, the wrfout file is not completed, can you help me to fix it? and eta_levels as follow
eta_levels =
1.00000 ,0.99920 ,0.99817 ,0.99685 ,0.99516 ,0.99299 ,
0.99019 ,0.98661 ,0.98201 ,0.97724 ,0.97230 ,0.96718 ,
0.96188 ,0.95638 ,0.95069 ,0.94480 ,0.93869 ,0.93236 ,
0.92580 ,0.91901 ,0.91215 ,0.90522 ,0.89822 ,0.89116 ,
0.88402 ,0.87681 ,0.86953 ,0.86217 ,0.85474 ,0.84724 ,
0.83966 ,0.83201 ,0.82428 ,0.81647 ,0.80859 ,0.80062 ,
0.79258 ,0.78445 ,0.77625 ,0.76796 ,0.75896 ,0.74976 ,
0.74030 ,0.73050 ,0.72000 ,0.70700 ,0.69100 ,0.67100 ,
0.64900 ,0.62400 ,0.59400 ,0.55900 ,0.51900 ,0.47900 ,
0.43900 ,0.39900 ,0.35900 ,0.31900 ,0.27900 ,0.23900 ,
0.19900 ,0.15900 ,0.11900 ,0.07900 ,0.03900 ,0.00000 ,
 
there are the rsl.error file and namelist.input file, and I only change e_vert=36 to e_vert=66 with adding eta_levels details, ./real.exe process is successful, but it occur the error when I run ./wrf.exe and model stops.
Thank you and waiting for your reply.
ps: I use wrf v3.9.1
 

Attachments

  • 20200303_namelist.input.jpg
    20200303_namelist.input.jpg
    65.8 KB · Views: 4,338
  • 20200303_rsl.error.0021.jpg
    20200303_rsl.error.0021.jpg
    111.4 KB · Views: 4,326
  • 20200229_rsl.error.0024.jpg
    20200229_rsl.error.0024.jpg
    104.6 KB · Views: 4,328
There are many CFL violations shown in your file. This means that your case is numerically unstable.
Please reduce time step, set w_damping =1, and epssm = 0.6, then try again.
 
and I want to ask you that in this model case, I want to simulate a hurricane case, but the whole hurricane case lasts about 10 days, and its track cover a very long distance in east-west longitude and south-north latitude, so I have to make my simulate domain so large to cover the hurricane case. and therefore e_we and e_sn in the namelist is so large, will it have any problem with model running? and please tell me how to fix or work it?
 
For hurricane simulation over a long period, the moving nest is a good option. With this option, you can always run coarse resolution in outer domain, and run high resolution in inner domain. This will save you computer time and run the case efficiently.
For more details, please see
https://www2.mmm.ucar.edu/wrf/users/docs/user_guide_v4/v4.0/users_guide_chap5.html#movenest
 
Thank you for your reply and advice.
When i instal wrf and wps, there are some warnings in the compile log of wrf and wps, but there is no ERROR with "Executables successfully built".
does compile warning can influence the silmulatiuon result?
what about warning in rsl.error.0000 during run ./wrf.exe?
 
hello professor,after configuring and compiling WRF and WPS, i run a tropical cyclone case with vortex—following option,and follow every step as basic option,and after running the wrf.exe, i get the wrfout file, but there is no tropical cyclone track information in the rsl.out.0000, and the rsl.out.0000 file is the same as the rsl.error.0000 file, is that right? can you fix the problem? thank you so much.
 
Hi, I'm trying to simulate July 2013 using the 3.7.1 version (WRF) and ERA-Interim as input data, and i have the same error (see below) and also I attached the namelist.input. Before i ran succesfully this same simulation using the 4.1.5 version with ERA-5 and ERA-Interim, but when I changed the version I have this problem.

This is the rsl.error.0000 file:
------ ERROR while reading namelist physics ------
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 10244
ERRORS while reading one or more namelists from namelist.input.
-------------------------------------------

I don't know how to resolve this problem viewing the rsl.error.0000 file. Any help is appreciated.
Thanks in advance.
 

Attachments

  • namelist.input
    7 KB · Views: 50
Hugo,
The best thing you can do is to look at the section of the namelist to which the error is indicated (for your error, it's in the physics section). Make sure there are no additional characters, or periods instead of commas, commas instead of periods, etc. I would advise to compare the namelist file to the default namelist.input file that comes with the model (you may need to download the model again to get that file). If there is a parameter for which you have added a column for, and the default namelist only has a single column value, you will need to remove any additional columns. Some parameters only expect a single value. You can also use the Registry.EM_COMMON file to determine whether a namelist parameter expects multiple columns. If it does, it will have "max_dom" in the registry line.
 
Top