Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

I'm having trouble running the WRF model.

subin

New member
Hi, I'm a student who just started learning about the WRF.
I want to run the WRF model, but I can't run it due to an error.
Attach the namelist and rsl files.
I would appreciate it if you could let me know what the problem is.
For your information, the data is using ERA5.
 

Attachments

  • namelist.input
    3.7 KB · Views: 6
  • rsl.error.0000
    882 bytes · Views: 4
  • rsl.out.0000
    762 bytes · Views: 5
Last edited:
Hi,
The error message in your rsl.error.0000 file states:

Code:
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:      70
 program wrf: error opening wrfinput_d01 for reading ierr=       -1021
-------------------------------------------

Did you run real.exe before running wrf.exe? If so, did it run successfully (the real.exe rsl files showed 'SUCCESS' at the end and you got wrfbdy_d01, wrfinput_d01, wrfinput_d02 files)?
 
Hi,
I ran real.exe before running wrf.exe.
The attached file is the file after running real.exe.
Running wrf.exe cancels immediately and does not create wrfout.
I don't know what the problem is. Please help me. :cry:
 
Hi Subin,
After you have run real.exe, did you check whether you got wrfinput_d01, wrfinput_d02 as Kwerner mentioned.
If you did not get these files, wrf.exe can not be run successfully.
 
I am not sure. Please check your namelist.input. For me , i am a little strange about your restart interval. It is more than your simulation hour. And i think your parent id for domain 1 should be 1.
 
Thank you for your advice.
I changed the time_step, and now I get another error message.
Do you happen to know how to resolve this error message?
 

Attachments

  • namelist.input
    3.7 KB · Views: 7
  • rsl.error.0000
    1.7 KB · Views: 7
  • rsl.out.0000
    11.4 KB · Views: 5
@subin
The error message showing in your real.exe rsl* files is

Code:
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:    3415
mismatch_landmask_ivgtyp
-------------------------------------------

It looks like this may have been an issue with WRF code prior to V4.1. Can you try to run with the latest version of WRF (V4.5) to see if it gets past that issue?
 
@Khin Myat
It's okay. Thanks for your help!

@kwerner
I found the cause of the problem. That is because the value of the boundary between the sea and land in the soil type is a value other than the sea. I run it with V4.5 as you advised, so it runs well. Thank you for your help!
 
Top