Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Make Clouds Transparent to Solar but not IR Radiation in WRF


New member

I understand that setting icloud=0 turns off the cloud effect on optical depth for shortwave radiation and longwave radiation (options 1,4); however, I am not seeing any way to turn off the cloud effect for just solar or just IR. Any help is greatly appreciated!

The cloud effect can always be turned off within the specific scheme you intend to use. For example, suppose you run with RRTMG radiation scheme, and you only want the cloud impact in LW but not in SW. You can simply add a single line


at the beginning of the code phys/module_ra_rrtmg_sw.F.

Note that this is just an example. You can follow the similar approach to modify whatever scheme you activate.
sorry for the typo. yes that is what I mean: ICLOUD = 0.
Please try and let me know whether it works.
Hi Ming,

No worries.

Setting ICLOUD = 0 gave me unintelligible error messages during compilation. Rather than try to debug them, I simply commented out the two "IF (ICLOUD .ne. 0) THEN" blocks within the RRTMG_SWRAD subroutine. That seemed to do the trick.

Bottom line is, you have to actually modify the source code - there is no way to do it in the namelist.

Thanks for your help.